1

Suddenly my laptop (with 16.04 LTS) cannot type parentheses ( and ). I have an Italian keyboard layout, and I've checked it is actually selected.

Strange thing is, the ability to type them seems to come and go randomly. I am puzzled.

What have I tried:

  • checked my keyboard layout, it's the same
  • checked this issue, seems much like my problem but on different keys. I've tried holding down the parentheses for some time and suddenly I can type them. After a while they stop again.
  • checked with xev, no output for ( press, then suddenly I have output.

On italian keyboard, they are typed using Shift+8 and Shift+9

  • What does the command gsettings get org.gnome.desktop.input-sources sources output? – Gunnar Hjalmarsson Feb 5 '17 at 16:27
  • @GunnarHjalmarsson it outputs [('xkb', 'it'), ('xkb', 'us')] – Cranio Feb 5 '17 at 20:19
  • Looks ok. The only advice I'm able to give is to switch explicitly to English (US) and then back to Italian. Doing so has fixed a similar problem for me. – Gunnar Hjalmarsson Feb 5 '17 at 20:45
  • @GunnarHjalmarsson alas, it was one of the first things I've tried. I begin to suspect a random hardware problem. Thank you anyway :) – Cranio Mar 5 '17 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.