5

After upgrading from Kubuntu 16.04 LTS to 16.10 the wired connection doesn't work. The wired connection is displayed in the Network Manager but is not possible to select the relative "Connect" button. The wi-fi connection is working.

The strange thing is that using a Kubuntu 16.10 live USB on the same PC the ethernet connection is immediately recognized and working.

These are some results :

    *-network                  
      description: Wireless interface
      product: Wireless 7260
      vendor: Intel Corporation
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: wlan0
      version: 73
      serial: a0:a8:cd:cc:e2:7d
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=iwlwifi driverversion=4.8.0-37-generic firmware=17.352738.0 ip=192.168.178.32 latency=0 link=yes multic
ast=yes wireless=IEEE 802.11
      resources: irq:93 memory:d0700000-d0701fff
 *-network DISABLED
      description: Ethernet interface
      product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
      vendor: Realtek Semiconductor Co., Ltd.
      physical id: 0
      bus info: pci@0000:03:00.0
      logical name: eth0
      version: 0c
      serial: c0:3f:d5:6d:86:9e
      size: 10Mbit/s
      capacity: 1Gbit/s
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonego
tiation
      configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=no multicast=yes port=MII
speed=10Mbit/s
      resources: irq:89 ioport:e000(size=256) memory:d0604000-d0604fff memory:d0600000-d0603fff
andrea@Sara-desktop:~$




[code]sudo ifconfig -a[/code]

eth0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
       ether c0:3f:d5:6d:86:9e  txqueuelen 1000  (Ethernet)                                                                                       
       RX packets 0  bytes 0 (0.0 B)                                                                                                              
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
       inet 127.0.0.1  netmask 255.0.0.0
       inet6 ::1  prefixlen 128  scopeid 0x10<host>
       loop  txqueuelen 1  (Loopback locale)
       RX packets 2060  bytes 181968 (181.9 KB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 2060  bytes 181968 (181.9 KB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.178.32  netmask 255.255.255.0  broadcast 192.168.178.255
       inet6 fe80::a2a8:cdff:fecc:e27d  prefixlen 64  scopeid 0x20<link>
       ether a0:a8:cd:cc:e2:7d  txqueuelen 1000  (Ethernet)
       RX packets 39431  bytes 53149953 (53.1 MB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 11174  bytes 1144582 (1.1 MB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0




ifconfig -a         

eth0: flags=4098<BROADCAST,MULTICAST>  mtu 1500                                                                                                    
       ether c0:3f:d5:6d:86:9e  txqueuelen 1000  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
       inet 127.0.0.1  netmask 255.0.0.0
       inet6 ::1  prefixlen 128  scopeid 0x10<host>
       loop  txqueuelen 1  (Loopback locale)
       RX packets 43498  bytes 2940360 (2.9 MB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 43498  bytes 2940360 (2.9 MB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
       ether a0:a8:cd:cc:e2:7d  txqueuelen 1000  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Following some suggestions I loaded driver r8168 instead of r8169, without success. The PC is a NUC DN2820FYK.

Thanks in advance for your help.

This is the result of the suggested command :

 dmesg | grep r8168
[    1.614987] r8168: loading out-of-tree module taints kernel.
[    1.615409] r8168: module verification failed: signature and/or required key missing - tainting kernel
[    1.615988] r8168 Gigabit Ethernet driver 8.042.00-NAPI loaded
[    1.637921] r8168: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
[    1.637930] r8168  Copyright (C) 2016  Realtek NIC software team <nicfae@realtek.com> 
[    1.722440] r8168 0000:03:00.0 enp3s0: renamed from eth0
  • 1
    Please edit your question and add output of dmesg | grep r8169 terminal command – Pilot6 Feb 5 '17 at 13:42
  • Using ubuntu 16.10 in a fresh installation, and after the first update, the same happened to me. The LAN was working fine. After the update only the wireless is working. I am using a Intel NUC. – Kaf Mar 18 '17 at 7:41
  • 1
    Check this answer. It solved my problem: askubuntu.com/questions/882806/ethernet-device-not-managed – Kaf Mar 18 '17 at 7:51
0

You need to use the r8168-dkms driver, and disable secure boot in your BIOS.

You'll also need to make sure that you're using a good ethernet cable and switch/hub (if you're using one).

  • Driver installed is already the r8168 and the secure boot is disabled. – Andrea1966 Feb 6 '17 at 19:01
  • @Andrea1966 then you really need to investigate your ethernet cable and other network hardware. Try plugging the computer directly into your router or modem using the ethernet cable and see if the link comes up... cause right now it's "link=no". – heynnema Feb 6 '17 at 20:40
  • heynnema, as I wrote the thing is that using a Kubuntu 16.10 live USB on the same PC the ethernet connection is immediately recognized and working. Therefore the ethernet cable is ok. – Andrea1966 Feb 7 '17 at 19:04
0

After upgrading to Ubuntu 17.04 and reading this thread, I was able to fix my Ethernet (eth0) connection.

In the file: /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

I added ",except:type:eth0" (without the quotes) to the end of the line. (You will notice it also says except:type:wifi and except:type:wwan)

Finally I created the file /etc/NetworkManager/conf.d/10-globally-managed-devices.conf by using sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

I forgot how to restart the service, so I rebooted instead. Ethernet fixed.

Hope this helps.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.