I tried to install the LTS version of Ubuntu (16.04) on my Asus win10 64 bit.

I made a usb bootable with ubuntu (and rufus application) I did the partition on my hard drive.

And when I launch The installation of Ubuntu right after I restart, whether I select Install Ubuntu or Try Ubuntu, it freezes on the loading screen, where you can see the dots under the name Ubuntu. It freezes and nothing happens, even after one hour. I have to restart the computer in the hard way.

I don't understand why it is not working, everywhere on tutorials or the docs, it seems that it should word.

I even updated pilots, but none of that worked.

  • You may need the nomodeset boot parameter if it has some newish Nvidia card and you need to have the USB correctly prepared if using Rufus: GPT/UEFI. Also read this: help.ubuntu.com/community/UEFI
    – user589808
    Feb 5, 2017 at 12:35
  • Old tutorials about BIOS machines aren't applicable.
    – user589808
    Feb 5, 2017 at 12:35
  • hello, what is the nomodset? how can I configure it? Feb 5, 2017 at 13:07
  • Assuming you'll be booting in UEFI mode - as you should - then at Grub menu, with the "Try Ubuntu" selected, press "e" to edit and add nomodeset after or instead of quiet splash. F10 to save.
    – user589808
    Feb 5, 2017 at 21:16
  • Hi, thank you for your answer, I actually added "acpi=off" after quietsplash and it works when I boot in. I have a new problem now, when I restart or switch off my computer, it freezes at the ubuntu quit screen, how can I fix that? thank you Feb 7, 2017 at 12:33

1 Answer 1


As the comment suggested, you need to disable legacy boot using the options in the BIOS. That seemed to work for me facing this same issue with both Ubuntu 18.04 and 16.04 on a Dell Inspiron 15 5000, trying to dual boot with Windows 10.

To be specific the BIOS has two options relevant to Legacy Boot on the same tab where you select the boot preferences and add/delete boot options. Those are the ones you would want to modify (disable).

Also note that I had to reset these options in the BIOS back to their original settings after successfully installing Ubuntu because otherwise it prompts a system repair and fails to boot into Windows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .