4

Recently I upgraded my computer (ASUS laptop, AMD86) from Ubuntu 14.04 LTS to the latest Ubuntu 16.10. I encountered the following issue: when I tried to launch "Files" (Nautilus) from the launch bar, the system briefly opened a window with the title "loading" and contents of the desktop (instead of the directory), then after a few seconds the window disappeared. The system generates an error report shown below

When I tried to launch the application by typing "nautilus" in terminal, it displayed the following error message:

(nautilus:8298): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist
Bus error (core dumped)

When I tried with "nautilus -c", the system displays the following error:

(nautilus:8349): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist
running nautilus_self_check_file_utilities
running nautilus_self_check_file_operations
running nautilus_self_check_directory

FAIL: check failed in nautilus-directory.c, line 1772
  evaluated: g_hash_table_size (directories)
   expected: 1
        got: 4
Bus error (core dumped)

When I tried with "gksu nautilus .", Nautilus is launched properly.

I have searched for blogs on similar issues from several sites and tried to follow their suggested techniques to fix the problem. These include:

  • purging and reinstalling nautilus,
  • re-installing ubuntu desktop,
  • changing ownership,
  • deleting nautilus configuration under .config

Unfortunately, none of these techniques work for me. In addition, when I try to open "gedit " from the terminal, similar error happened as well. The system briefly opens up "gedit" and then disappeared with an error message "bus error (core dumped)". Again, "gksu gedit " is working properly.

It seems to me the error was not caused by "nautilus" nor "gedit" installation, rather there might be some settings that were not configured properly during upgrade to 16.10. The problem is that I don't know how to investigate the true cause of this error. This also gives me an uneasy feeling that this error might cause other applications to fail on the system.

I would appreciate if someone could guide me in investigating the root cause of this issue (for example, which log or config file to look at).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.