3

I have a laptop (Dell - Inspiron 14 3000 Series) that came with Windows 10 installed. I want to install Ubuntu to the system, but there's a small (or maybe large) issue with that. The laptop storage drive is a 32GB eMMC Flash Drive. From what I can see, the BIOS/UEFI doesn't support booting from this device.

This absolutely baffles me, considering it boots up into Windows from that drive, yet there's no option to select it in the menu. Even more disconcerting is that when I install Ubuntu onto the drive, I turn on the machine and it instantly runs hardware recovery because it can't find a bootable OS.

Is there some way I'd need to install Ubuntu to the device for it to run properly? Steps I'd need to take for the system to install and run from the eMMC drive? (Also, I know 32GB isn't a lot, but I can do a lot more with it in Ubuntu than I can with Windows 10 where it's likely to become so cluttered that I'd need to refresh the machine every three months.) Any help with this would be fantastic. Thanks in advance.

(Other specs include Celeron N3050, 4GB DDR3, 768p 14" display.)

EDIT: SOLVED. Changing Secure Option ROM to access some weird file system? Apparently there's an onboard chip that has to reference the new OS. It's essentially encryption between the storage drive and the BIOS.

  • How did you install Ubuntu "when I install Ubuntu onto the drive" ? Did you take the disk out and used it in another computer ? That might not work. Did you read through the UEFI help page ? help.ubuntu.com/community/UEFI – albert j Feb 5 '17 at 5:25
  • You can't remove the drive? It's soldered to the mobo. I've tried. The help page is so unspecific, it completely pans over this issue. – user639089 Feb 5 '17 at 5:37
  • EDIT: SOLVED. Changing Secure Option ROM to access some weird file system? Apparently there's an onboard chip that has to reference the new OS. It's essentially encryption between the storage drive and the BIOS. – user639089 Feb 5 '17 at 6:08
  • Does your computer work well when booted from a USB drive or memory card reader? In that case an alternative is to run Ubuntu or a community flavour of Ubuntu persistent live or installed to a USB pendrive or memory card. See this link and links from it, ubuntuforums.org/showthread.php?t=2230389 – sudodus Feb 5 '17 at 6:11
  • 1
    If you have solved your problem, please post an answer instead of editing the question. – muru Feb 5 '17 at 7:47
2

I spent about an hour before finding a solution via trial and error. Thank you to all who assisted. I asked this question on two platforms, and my response is shared between them. This was the solution: "--In order for the system to recognized the installed OS, you must ensure the system is using UEFI boot mode as well as enabling Firmware TPM BEFORE installation. Secure boot MUST be off for installation and after installation. Legacy Option ROM should be disabled. After install, the system will recognize the OS and boot properly after the TPM check which will only occur at the very first bootup and never occur again." My Ubuntu Forums Post Explaining Installation

| improve this answer | |
  • 1
    The link does not work - did you perhaps mean to link here? ubuntuforums.org/… – Johan May 6 '19 at 19:54
  • This doesn't seem to work if the ISO is written to a USB in legacy format. – chx101 Jul 30 '19 at 20:31
  • I don't guide or provide support for legacy installations as I don't use any. Hopefully someone else on the forum might be able to provide a solution! – user639089 Jul 31 '19 at 21:19
  • This solution worked for me, with one additional detail: In order to boot from the live USB stick containing the Ubuntu iso I had to press F12 immediately after powering up the device. F12 took me into BOOT OPTIONS where I was able to manually select the USB boot option. There is no other way to boot from USB when all the other settings are set correctly, per the user639089 solution. I have the exact same hardware specs as in the original question. – hoatzin Oct 6 at 3:00
1

I have a Dell Inspiron 11 3000. Here's what I did:

  • disable secure boot
  • disable legacy boot, but keep UEFI.

And install normally. It shouldn't give problems. You need to check and remove any unwanted boot entry in the same screen where you disable secure boot. Our storage device is /dev/mmcblk0.

Since we have exactly the same hardware and it's not a very popular config, you can contact me directly if you need any other help.

| improve this answer | |
  • I have Inspiron 14 and I have been trying to install Zorin OS (32bit). It installs but can't boot. The installer is run from a bootable USB in legacy mode. Since I'm flashing in legacy mode, the system won't see the USB in EFI – chx101 Jul 30 '19 at 20:36