0

I have a Brother HL-1110 printer connected to my computer, it was working well although it took me long time to install it in first place

suddenly it stopped responding, and the small icon in the upper left corner of the screen that shows print jobs stopped appearing.

I tried to uninstall the package and install it again, although I know nothing about using the Terminal.

no progress, in addition to that now when I try to open the printer from the System Settings -> Printers -> Select Device , I get this message:

System Problem detected
Do youo want to report the problem now?

enter image description here

I'm using Toshiba TeCRA with Ubuntu 16.04 LTS

I need to reinstall the printer that's it

I tried to follow the official Brother instructions, I got the following:

Fetched 2,547 kB in 21s (116 kB/s)
Reading package lists... Done Reading package lists... Done Building dependency tree
Reading state information... Done Package ia32-libs is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: lib32ncurses5 lib32z1

E: Package 'ia32-libs' has no installation candidate dpkg -x hl1110lpr-3.0.1-1.i386.deb / dpkg -x hl1110cupswrapper-3.0.1-1.i386.deb / (Reading database ... 272286 files and directories currently installed.) Removing hl1110cupswrapper:i386 (3.0.1-1) ... Purging configuration files for hl1110cupswrapper:i386 (3.0.1-1) ... dpkg-deb: building package 'hl1110lpr' in 'hl1110lpr-3.0.1-1a.i386.deb'. dpkg -b ./brother_driver_packdir hl1110lpr-3.0.1-1a.i386.deb dpkg-deb: building package 'hl1110cupswrapper' in 'hl1110cupswrapper-3.0.1-1a.i386.deb'. dpkg -b ./brother_driver_packdir hl1110cupswrapper-3.0.1-1a.i386.deb dpkg -i --force-all hl1110lpr-3.0.1-1a.i386.deb (Reading database ... 272284 files and directories currently installed.) Preparing to unpack hl1110lpr-3.0.1-1a.i386.deb ... Unpacking hl1110lpr:i386 (3.0.1-1) over (3.0.1-1) ... Setting up hl1110lpr:i386 (3.0.1-1) ... dpkg -i --force-all hl1110cupswrapper-3.0.1-1a.i386.deb Selecting previously unselected package hl1110cupswrapper:i386. (Reading database ... 272284 files and directories currently installed.) Preparing to unpack hl1110cupswrapper-3.0.1-1a.i386.deb ... Unpacking hl1110cupswrapper:i386 (3.0.1-1) ... Setting up hl1110cupswrapper:i386 (3.0.1-1) ... lpinfo: cups-deviced failed to execute. lpadmin -p HL1110 -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-HL1110-cups-en.ppd lpadmin: Bad device-uri scheme "usb".

#########################ls: cannot access '/usr/share/ppd/*.ppd': No such file or directory

# lpinfo: cups-deviced failed to execute.

0 (I): Specify IP address. 1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->1

lpadmin -p HL1110 -v usb://dev/usblp0 -E -P /usr/share/cups/model/brother-HL1110-cups-en.ppd lpadmin: Bad device-uri scheme "usb". Test Print? [y/N] ->y

wait 5s. echo HL1110 \| lpr -P HL1110

What does it mean "lpinfo: cups-deviced failed to execute**", "lpadmin: Bad device-uri scheme "usb"."

what should I do now?

  • 2
    Use the official drivers Provided by Brother from this answer to reinstall. – L. D. James Feb 4 '17 at 22:25
  • I have dozens of hours invested in problems with my Brother HL-1435, both with the CUPS drivers and with the official Brother drivers. The margins are incorrect (with some Gnome software) with many driver variants. The ones with good margins tend to only print a single job before requiring a reboot. Summary: don't try too hard, it's likely not worth the effort. Trade your printer for something else better supported. – DS Justice Feb 8 '17 at 17:38
  • @kimo I don't understand your response. – L. D. James Feb 8 '17 at 17:42
0

solved

I installed a fresh Ubuntu 16.04 and went to http://support.brother.com and downloaded "Driver Install Tool" and followed the instructions and then.... It is working

I think some one was hacking on my computer and tried to get all my past printing jobs, just a guess, so he or she destroyed something related to the printer installation

now it is working very well

thanks to everybody and good luck

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.