1

I am attempting to compile the program Goozzee, which seems the only program of its niche type (personal desktop knowledge base using topic maps), so I'm pretty invested in getting it going.

These are the compile/install instructions that were included:

aclocal
autoconf
automake --add-missing
./configure
make
make install

Ubuntu seems to require wx-common, so I installed that.

Instructions to automake work, but

sudo ./configure

returns:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
./configure: line 2893: syntax error near unexpected token `5.5.0,'
./configure: line 2893: `MYSQL_CLIENT(5.5.0, embedded)'

so its a ./configure problem, which is common, but no one on the internets seems to also have information on the syntax error that involves MYSQL_CLIENTS or token '5.5.0, '

I have both packages pk-config, and pkg-config, but neither seem to make a difference I unpacked autogen.sh, but I don't know actually install it as there is a division in the application folder for personal and network editions, and the folder that contains the editions has also application information. I put it in the PE folder.

./autogen.sh && make && sudo make install
grep: ./configure.ac: Permission denied
Preparing the project build system...please wait

Found GNU Autoconf version 2.69
Found GNU Automake version 1.15

Warning:  libtoolize does not appear to be available.  This means that
the automatic build preparation via autoreconf will probably not work.
Preparing the build by running each step individually, however, should
work and will be done automatically for you if autoreconf fails.

ERROR: Unable to locate GNU Libtool.

ERROR:  To prepare the project build system from scratch,
        at least version 1.4.2 of GNU Libtool must be installed.

autogen.sh does not need to be run on the same machine that will
run configure or make.  Either the GNU Autotools will need to be installed
or upgraded on this system, or autogen.sh must be run on the source
code on another system and then transferred to here. -- Cheers!

I have tried all day on this. I have not compiled on this machine yet, nor did I know how to this morning. Easy instructions and searched troubleshooting terms/suggestions are not working.

  • For that matter, you must not run ./configure with sudo unless all your files are owned by root, as that would cause a mess with some files owned by root and others not. The same goes for make. – fkraiem Feb 4 '17 at 12:50
  • Thanks, well, It says: './configure: line 1931: config.log: Permission denied ./configure: line 1941: config.log: Permission denied' if I don't put sudo. It returns the same errors as before if I do. – CedarSage Feb 4 '17 at 19:45
  • As for the source, the instructions are from the website with typos, but in the package itself without. The package of source code is from the goozzee website. I don't know what I'm doing with sudo. Just sudoing in the dark, heh heh. In the past, instructions didn't work without sudo, so I just sudo most things. Maybe I shouldn't. Thankyou. – CedarSage Feb 4 '17 at 19:51
3

I'm the one developing Goozzee.

I reproduced your problem on my Ubuntu 16.10 VM and I think I have the solution.

As far as I understand, the MYSQL_CLIENT macro is located inside the mysql.m4 script. But this script isn't automatically installed with autotools.

What I did is install the libmysqld-dev package. That fixed the issue.

I also installed the following packages that are required by Goozzee: libwxgtk3.0-0v5 and libwxgtk3.0-dev.

Please let me know if it worked for you.

| improve this answer | |
  • 1
    Welcome to AskUbuntu! Unfortunately this site is not modelled like a forum for conversation. Instead you're meant to either ask a question or provide an answer to a question, both of which should only be done in their dedicated section. If you write something that doesn't fit its section or something that is neither a question nor an answer it will likely be deleted. That's why I removed the part of your post that didn't answer the question. You may want to take the tour to get a better idea of how AskUbuntu and StackExchange work. – David Foerster Feb 4 '17 at 12:48
  • Installing libmysqld-dev, libwxgtk3.0-0v5, and libwxgtk3.0-dev did not fix the issue, yet. It still returns the same result about MYSQL – CedarSage Feb 4 '17 at 19:47
  • Please don't forget that, after installing these packages, you must re-run aclocal, automake and autoconf. – Michel Laglasse Feb 8 '17 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.