OS – Ubuntu 16.04, 64-bit.

I just bought a Moto G4. I plug the USB cable into my computer, then I go to Apps > Play Music, and it says, "Copy music to your phone with a USB cable." Suddenly, my computer recognizes the Moto G4 as an external drive, and opens a Nautilus window for it.

However, there appears to be nothing in /media/jps ("jps" being my user name). Screenshot. Also, when I try to hover over the folder name in Nautilus, it just gives the file directory for the location as "mtp://[usb:003,022]/.

When I try to copy-paste some .mp3 files onto the device, the paste option is grayed out on the right-click context menu. It's as though it thinks there's nothing on my clipboard. And of course, I can't just use cp in the terminal, because the device directory above is not actually a real directory on my computer that the terminal can recognize.

What's going on?


I touched the bar on the top of my smart phone screen, and it gave me the option of switching between USB modes – "charging", "file transfers (MTP)", "photo transfer (PTP)", and "MIDI". I switched from MTP to PTP, and suddenly I was able to paste files onto the device! So problem solved, I guess.


I got the same problem and in particular I wasn't able to paste files in the internal memory.

I solved in this way ( remember to set MTP mode )

  • Go to “settings” and find “about device”
  • Tap on build number few times until you see
    “Developer Mode Has Been Turned On”
  • then go to “developer options”, make sure the USB debugging checkbox is ticked.

Now you should be able to copy files in the internal memory.


Just open destination folder on phone and source folder on your PC.then drag from PC folder and drop into phone folder and voila.that worked for me

  • Were you also unable to copy/paste using cp a CLI? In my experience, I've never been able to do something in the graphical interface that I was unable to do using the command that executes the same action.
    – Hee Jin
    May 15 '18 at 16:42
  • 1
    This is not an answer, this is the expected behavior, and clearly the OP is having a problem with exactly this.
    – Todd
    May 15 '19 at 19:09

I do not have SD card in my tablet and I was needed to copy files/folder from PC to tablet's internal memory. I was able to copy everything I needed just to root directory of my internal memory (Next to Android, DCIM, documents and other folders). Also I could create folders/sub-folders but could not copy anything to them. Root directory in my case was enough - then using internal Android file manager it was possible to cut/paste files/folder from root directory to anywhere else.

I could do it using MTP mode. Developer mode not required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.