0

Installed Ubuntu 16.04 on my Windows 10 updated Lenovo Laptop in UEFI mode(would not work in legacy). I got a message during install that if continued with UEFI mode install one or all OS's bootloader might not work. Well sure enough ubuntu install is complete and no boot loader is coming up. Been doing some reading but not real sure where to go from here. Tempted to scrap windows and format drive and install Ubuntu only. I see both partitions not sure if windows has been compromised or not. Currently only able to boot into LiveUSB and have tried to repair grub with no success.

 Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
 Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 4096 bytes 
I/O size (minimum/optimal): 4096 bytes / 4096 bytes 
Disklabel type: dos 
Disk identifier: 0x39063905 
Device Boot Start End Sectors Size Id Type 
/dev/sda1 * 2048 1026047 1024000 500M 7 HPFS/NTFS/exFAT 
/dev/sda2 1026048 415424511 414398464 197.6G 7 HPFS/NTFS/exFAT
/dev/sda3 415424512 419424255 3999744 1.9G 82 Linux swap / Solaris
/dev/sda4 419424256 625141052 205716797 98.1G 83 Linux Disk 

/dev/sdb: 1.9 GiB, 1992294400 bytes, 3891200 sectors 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: gpt Disk identifier: 236ADC0B-976D-4DC2-83C8-51953D78FEF8 
Device Start End Sectors Size Type 
/dev/sdb1 2048 3891166 3889119 1.9G Microsoft basic data
  • If your W10 was updated from W7, then you probably have a legacy W10 install. Please add the output of sudo fdisk -l so we can see what partitioning your disk has and what boot partitions are present. Lenovos may boot either mode, you can set the preference in BIOS/UEFI settings. – ubfan1 Feb 4 '17 at 5:45
  • The laptop was originally Windows 8. I tried to do a Legacy/CSM install off USB of Ubuntu but it would not work until I switched BIOS back to UEFI mode. Originally during install I used sda4 for the Bootloader but that didnt work, so I tried to put it on sda2 (windows ) that did not work. Finally I tried to put it on the sda. – SteamN Feb 6 '17 at 7:09
  • /dev/sda1 * 2048 1026047 1024000 500M 7 HPFS/NTFS/exFAT /dev/sda2 1026048 415424511 414398464 197.6G 7 HPFS/NTFS/exFAT /dev/sda3 415424512 419424255 3999744 1.9G 82 Linux swap / Solaris /dev/sda4 419424256 625141052 205716797 98.1G 83 Linux – SteamN Feb 6 '17 at 7:38
  • You can edit your question to add information, and use the code tags for formatting. Is the disk gpt? You didn't post all the output. You don't appear to have an EFI partition, unless sda1 is it but the partition type is wrong. – ubfan1 Feb 6 '17 at 16:41
  • I believe the disk is gpt as I did the partition in windows. I am still trying to figure out the code tags forgive me. But the info from fdisk -l that I posted was copy and pasted. – SteamN Feb 7 '17 at 18:20
1

You appear to have a legacy install of Windows 10, since your disk is partitioning type DOS, not gpt. This is odd if your machine was originally Windows 8, but maybe it had been upgraded from Windows 7 to result in the legacy install. This implies you need to install Ubuntu in legacy mode too if you dual boot. In the BIOS/UEFI settings, there may be a choice of which boot type is preferred, legacy or UEFI. If you see such a choice, put legacy first to allow the Ubuntu install media to boot in legacy. The install media can boot both ways, so by setting legacy before UEFI, that should force the legacy boot. It appears you have the necessary linux root and swap partitions, so early in the install, select "something else" and select those partitions for / and swap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.