2

So I've installed it and these are the results of an attempt to start it:

user@hostname:~$ sudo service calendarserver status
● calendarserver.service - LSB: Calendar and Contacts Server
   Loaded: loaded (/etc/init.d/calendarserver; bad; vendor preset: enabled)
   Active: active (exited) since Fri 2017-02-03 12:12:09 EST; 4min 24s ago
     Docs: man:systemd-sysv-generator(8)

Feb 03 12:12:09 hostname systemd[1]: Starting LSB: Calendar and Contacts Server...
Feb 03 12:12:09 hostname calendarserver[4663]:  * Not starting calendarserver, disabled via /etc/default/calendarserver
Feb 03 12:12:09 hostname systemd[1]: Started LSB: Calendar and Contacts Server.
Feb 03 12:16:09 hostname systemd[1]: Started LSB: Calendar and Contacts Server.

I think this means it was already running. How do I verify that it's working properly? I've tried connecting to it at http://127.0.0.1:8008/ but no dice.

Hmm... OK I was watching the system log and didn't see much that indicated a new server running. So I looked here as the message advises: /etc/default/calendarserver

Apparently the portion that starts the server is start_calendarserver=yes and that needs to be uncommented. A restart afterwards shows log traffic indicating a new server is running. ...but what next?

OH.

Feb  3 12:27:02 hostname calendarserver[5570]: txdav.common.icommondatastore.InternalDataStoreError: No such socket file: /var/run/postgresql

Apparently it uses Postgresql. I'll install that and restart. You would think that if it needed something there would be a dependency. Sheesh. OK. This time started without errors. Will try to hit it again. Nope.

Apparently I need to have extended file system attributes, so I've fixed that and remounted the drive.

Now I'm seeing this in the logs:

Feb  3 13:11:47 hostname calendarserver[10440]: usr/lib/python2.7/dist-packages/twext/python/__pycache__/_cffi_twext_python_sacl_xe128630fxbbd600c.c:2:20: fatal error: Python.h: No such file or directory

I also noted the above when trying to execute some of the calendarserver_* scripts. ...OK I've figured that one out also. Another broken dependency which is to say that it also needs python-dev. Still not working though and this time no errors reported. :-|

3
  • Which howto did you use for Calendar server ? Did you look at /usr/share/doc/calendarserver/ ? And if you want to quickly run a calendar server, have a look at Baikal or Radicale or the one from Nextcloud. I found those much easier to configure than the Apple cal. server.
    – albert j
    Feb 3 '17 at 17:53
  • 1
    There should be a way to mark packages as "Known to be non functional" so that people don't waist time with them. :-| Trying radicale.
    – user447607
    Feb 3 '17 at 19:25
  • 1
    My impression is that Apple calendar server is a fine piece of software, but with possibly a higher admin learning curve than some other calendar servers. Good luck with Radicale !
    – albert j
    Feb 4 '17 at 2:38
1

What worked for me:

sudo apt install calendarserver postgresql
sudo -u postgres createuser caldavd --no-createdb --no-createrole --no-superuser
sudo -u postgres createdb --owner=caldavd caldav
sudo -u caldavd psql -f /usr/lib/python2.7/dist-packages/txdav/common/datastore/sql_schema/current.sql caldav

Edit /etc/default/calendarserver uncomment start_calendar_server=yes

reboot

For proper production mode: you need to edit the /etc/caldavd/caldavd.plist and enable https and point to a proper directory.

You want to have ext4 file system for the extended attributes

YMMV

There's a complete writeup on the steps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.