6

I run a 14.04 system and pick up libreoffice from the official ppa (http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main).

This morning the ppa provided a bunch of updates. While incorporating them, I got multiple warnings of the form

W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n

and the advice to

W: You may want to run apt-get update to correct these problems

(which did not help when run)

Oddly, I do not seem to have the package libreoffice-l10n installed.

These warnings do not seem to have much effect, in that the updates succeeded.

Now, however, they show up on every subsequent sudo apt update or similar command.

How can I rid my system of these warnings?

  • 1
    sudo apt-get update && sudo apt-get upgrade doesn't help ? – GAD3R Feb 3 '17 at 17:14
  • Thanks for the response. The warnings are issued at the sudo apt-get update step, and upgrade reports no packages to install or upgrade. – Organic Marble Feb 3 '17 at 17:55
  • 1
    Hello! I would like to hook up to this thread as I had the same problem just some minutes ago. I wanted to add the wine repository and ended up with about a hundred warning lines for "libreoffice-l10n". I tried "sudo apt-get update", "… dist-upgrade", "… upgrade", "… install -f", "… autoremove" and none of it helped. – Jens Feb 3 '17 at 21:45
  • 1
    I have found that if I disable the libreoffice ppa and run sudo apt-get update I do not get the warnings. Of course this moves all the libreoffice packages to local. – Organic Marble Feb 3 '17 at 22:25
  • 2
    I can confirm that these warnings are harmless. In the meantime I installed wine and other things and ran some updates too and all went fine. But anyhow, it would be much nicer with a proper LO5.3 ppa. Hopefully this will be fixed in a few days. – Jens Feb 7 '17 at 23:30
2

This problem was apparently fixed today, 3rd April 2017. From an older comment of mine:

Those warnings are probably due to a minor bug in the package, which will hopefully be fixed in a future version. Meanwhile, they can safely be ignored, especially if the package is not installed.

| improve this answer | |
  • Thanks from me too. All bugs are gone – unfortunately except one: "libreoffice-l10n-de" is still not updating. – Jens Apr 14 '17 at 8:17
  • @Jens Yes the l10n packages seem to have another bug where they don't "see" that the main libreoffice paxkages are installed, and so they can't be installed because of "missing dependencies"... – fkraiem Apr 14 '17 at 10:22
  • @fkraiem: Thanks for the info. That surely means probably another two months of waiting for a solution. Well, it could be worse. LO is running – if I don't use hyphenation – and I'm fine with that for so far :) – Jens Apr 15 '17 at 11:23
  • This last issue has been solved today with an update for "libreoffice-help-de", "libreoffice-help-en-us" & "libreoffice-l10n-de". Everything is working fine now and even a hanging of the muon updater – obvioulsy caused by this libreoffice update problem – has also been solved too. To whom so ever: THANK YOU VERY MUCH :)) – Jens Apr 20 '17 at 9:02
3

Libreoffice 5.3 was released (today) and does not support all languages yet. For example German is not supported*. I think this might cause the problem. Sadly, the human theme was also removed (why?), so I decided to

  • switch back to Libreoffice 5.2
  • Remove ppa:libreoffice/ppa
  • and choose the one for 5.2:

    sudo add-apt-repository ppa:libreoffice/libreoffice-5-2
    

    sudo apt-get update

If you made the same mistake as I did, and already upgraded to 5.3, you have to run:

sudo apt-get remove --purge libreoffice-core libreoffice-common
sudo apt-get autoremove --purge

and reinstall LibreOffice. The problem lines no longer appear.

*https://wiki.documentfoundation.org/ReleaseNotes/5.3/de#Lokalisierung

| improve this answer | |
  • 1
    Thank you for the response. My goal is to retain 5.3 and get rid of the warnings. – Organic Marble Feb 5 '17 at 2:50
2

I want to provide a little more detail and amplify Ophilon's answer.

  1. Remove the current ppa for LibreOffice

    sudo apt-get-repository --remove ppa:libreoffice/ppa

  2. Add the older respoistory (5.2)

    sudo add-apt-repository ppa:libreoffice/libreoffice-5-2

  3. Purge LibreOffice

    sudo apt-get remove --purge libreoffice-core libreoffice-common sudo apt-get autoremove --purge

  4. Run sudo apt-get update

  5. When I tried to install 5.2 using apt, however, I got broken dependencies. So I suggest downloading this package:

http://downloadarchive.documentfoundation.org/libreoffice/old/5.2.5.1/deb/x86_64/LibreOffice_5.2.5.1_Linux_x86-64_deb.tar.gz

or http://downloadarchive.documentfoundation.org/libreoffice/old/5.2.5.1/deb/x86_64/LibreOffice_5.2.5.1_Linux_x86_deb.tar.gz for 32-bit systems

  1. Extract the archive and change to the /DEBS directory (that's the full path).

    6a. If you have been using Nautilus up to now, right-click and select "Open in Terminal".

  2. Now install

    sudo dpkg -i *.deb

| improve this answer | |
  • 1
    Thank you for the response. My goal is to retain 5.3 and get rid of the warnings. – Organic Marble Feb 5 '17 at 2:50
  • I have been informed by one user (Geno) that the broken package error in step 5 was fixable (at least on that user's own system) by purging ure, uno-libs3, hyphen-* and libreoffice-style-human before the installation. But the user doesn't exactly know which of those was the root cause (nor do I). – gracious1 Feb 13 '17 at 19:11
1

I had the same problem, my solution that worked on my system:

  1. Temporarily comment with # the lines in the libreoffice.list so that the update process does not use it

  2. sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get clean

  3. sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade && sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get clean

  4. Uncomment the lines in the libreoffice.list

  5. sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade && sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get clean

In my case it updated without problems after I took those steps.

| improve this answer | |
  • Sorry, but that did not fix the problem for me. I still get the warnings when I execute step 5 of your procedure. – Organic Marble Feb 9 '17 at 16:41
  • I find no file libreoffice.list on my computer. Which file exactly do you mean? – Adalbert Hanßen Mar 19 '17 at 9:41
0

I'm using the package manager built into elementary OS, and received the same error messages (double checked through apt-get) Ignoring Provides line with DepCompareOp for package libreoffice-l10n.

What I did to resolve this was to disable the download of the libreoffice foreign language packages (other than English). By default, the foreign language packages themselves were disabled, but their associated help files were not e.g. these packages.

Screenshot

Disabling both the language files and the help files in my package manager "details of updates" list resulted in a clean update and no error messages.

| improve this answer | |
  • For me, it was fixed by an update pushed out on 4/3/2017. See accepted answer. – Organic Marble Apr 10 '17 at 23:48
  • Was this a general update or a specific package? The accepted answer doesn't elaborate. I've been trying to update a few times over the last week and only disabling the help files worked. – Nukolas Apr 10 '17 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.