4

Inkscape does not see any new installed font.

  1. Installed inkscape 0.92 (snap package)
  2. It works and recognizes all default fonts of Ubuntu 16.10
  3. Installed new font with font manager (Roboto ttf font family)
  4. Restarted inkscape and system. Inkscape does not "see" new font.
  5. Installed roboto font by copying directly to the usr/share/fonts/ folder. Refreshed font cache. Restarted system. Inkscape still does not see new font.

I've tried with couple of different fonts, and the situation is the same.

New fonts are appearing in LibreOffice for example, but not in Inkscape (maybe I need to ask elsewhere if it's Inkscape's problem?)

6

this is a known issue with the snap package format for Ubuntu. As far as I understand, they do only find fonts that you put into the .fonts directory in your home directory.

https://bugs.launchpad.net/inkscape/+bug/1655609

  • Or, if I read this again, maybe not?... Sorry if wrong, but you can give the workaround a try. – Maren Feb 6 '17 at 18:00
5

Check which Inkscape you use: snap or apt.

In the Ubuntu 18.04 AppCenter, there are two different versions of Inkscape, one from the Snap Store, one from ubuntu-bionic-universe.

If you have the first one, you’re in trouble, there are no fonts you have installed and a Windows XP-like interface. Remove this version and get the second one and you'll be happy then.

  • 2
    This is not a duplicate; installing the apt version is an alternative. – abu_bua Nov 27 '18 at 15:44
  • This worked for me, fonts are now visible! Thank you. Here are 2 commands to remove snap, then install Inkscape via command line: ubuntuhandbook.org/index.php/2017/01/… – Tomáš Votruba Apr 7 at 21:56
1

I just went through this with Ubuntu 18.04 and Inkscape 0.92. Putting fonts (truetype) in ~./fonts didn't work. Moving them to /usr/share/fonts/truetype did.

After putting the fonts in ./fonts and not seeing them in inkscape found here interfaces: mount host system fonts in desktop interface #3889 I executed

$ snap refresh --channel=edge core

... which didn't help.

I then move the fonts to /user/share/fonts/trutype and could see the fonts in Inkscape.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.