1

The lab I work for recently got a new Dell Precision Tower 5810. We have a 4TB HDD in there in addition to the smaller one it traditionally comes with. Because the larger institution has standardized IT support, we cannot mess with the smaller drive and thus must use the 4TB for booting Ubuntu. I am trying to install Ubuntu 14.04 from a LiveCD which we have used in the past. Previous installations were successful on other computers of the same product name. The largest differences between the new computer and the old ones, as far as I know at the moment, is that the new computer has next-version processors and 2x the additional HDD space.

When I install Ubuntu on the HDD, it claims to be successful. Furthermore Windows' disk manager, although unable to identify the Ubuntu partitions, acknowledges that something is there. However, when I try to boot the computer from the 4TB drive, it insists it cannot find a bootloader.

I have reformatted the drive and reinstalled Ubuntu but that does not help. While reinstalling Ubuntu, I have also tried putting it in different sections on the HDD (ex. beginning versus end of the drive). I have also used the LiveCD to attempt a purge of Grub; no success there.

Because of this, I am starting to think that the computer just isn't able to boot from a 4TB drive. However, I have yet to find documentation to support this idea.

Does anyone have any ideas? Please keep in mind, I don't have much depth when it comes to the technical aspects of computers.


Edits:


Per a comment below, I am moving some relevant information into the original post.

Here is the boot info for the initial state of the issue. http://paste.ubuntu.com/23920806

I thought the issue might be were Grub was installed so I changed it and got the following. http://paste.ubuntu.com/23921965

I think I might have found a post about a similar problem, but there is no answer. Boot-Repair: "core.img can not be found"

To clarify, we are installing Ubuntu 14.04.3 on a secondary drive which has been partitioned using GPT. We use legacy boot. We install Grub on the secondary drive and then change the BIOS settings to boot from there instead of the primary drive. We do this using a live cd. This procedure has worked on previous Dell Precision Tower 5810s that have 2TB secondary drives. We are now trying to do this for a 4TB secondary drive. Based on the boot info, it appears that grub is not looking in the correct place for one of its image files. However, I have not been able to find a way to correct this. I have tried reinstalling Grub as well as reinstalling Ubuntu. In the case of reinstalling Ubuntu, I have tried both with and without reformatting the entire drive.


So, I tried to do this with a 2TB drive just like we have in the past. As can be seen at the following boot info page, it does not appear to have the same missing image file issue. However, the computer still will not boot from it. Please note that in this case, the 2TB drive is in the new computer so it is sdb not sdc. http://paste.ubuntu.com/23955960/


So, it was brought to my attention that using a GPT partitioned drive for Grub requires a dedicated Grub partition. I was previously unaware of this because that particular information appears as a short paragraph in the Grub installation instructions (https://help.ubuntu.com/community/Grub2/Installing#BIOS.2FGPT_Notes) but is not in the general Ubuntu installation instructions. At this point, I have put the 4TB drive back into the new computer and have resumed attempts to install Ubuntu on it. However, despite following the online instructions to the best of my knowledge, Grub still does not work. Based on the boot info, the previous issue of a missing image file appears to have re-emerged. The following boot info is from after an attempt to purge and reinstall Grub. The screenshot shows what GParted displays when examining the 4TB drive. When installing Grub, during both Ubuntu installation and Grub reinstallation, I select sdb as the installation location for Grub.

http://paste.ubuntu.com/23958163/

Screenshot with GParted showing the 4TB drive partitions


As requested by oldfred, I have checked the Secure Boot settings. I am working on Windows 7 Enterprise so msinfo32 does not display this status. However, I was able to check by accessing the boot settings upon booting the computer. If anyone knows a simpler method, feel free to share. Regardless, below are two images showing the current Secure Boot configuration for the computer in question.

Image of computer screen showing legacy ROMs enabled

Image of computer screen showing Secure Boot disabled


Reinstalled but not purged using Boot-Repair: http://paste.ubuntu.com/23969162/


Per ubfan1's suggestion (and apparent "fine print" at https://help.ubuntu.com/community/DiskSpace#BIOS-Boot_or_EFI_partition_.28required_on_GPT_disks.29), I have moved the bios_grub partition to the front of the disk. However, it still doesn't boot.

http://paste.ubuntu.com/23990368/

Per ubfan1's suggestion (and https://help.ubuntu.com/community/DiskSpace#Separate_.2Fboot_.28sometimes_required.29), I created a separate boot partition. I then reinstalled Ubuntu but it still will not boot.

http://paste.ubuntu.com/23990755/

I have used Boot-Repair to purge and reinstall Grub but it still won't boot.

http://paste.ubuntu.com/23990829/


Per oldfred's comment, I have tried to add the "boot" flag to a partition. I have done so in the following configurations without success.

+---------------+-----------+-------------+-------------+-----------------------+
| configuration | partition | mount point | file system |         flags         |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   | bios_grub legacy_boot |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |    /boot    |    ext4     |                       |
|       1       +-----------+-------------+-------------+-----------------------+
|               |     3     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |         boot          |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |    /boot    |    ext4     |                       |
|       2       +-----------+-------------+-------------+-----------------------+
|               |     3     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |       bios_grub       |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |             |    ext4     |      legacy_boot      |
|               +-----------+-------------+-------------+-----------------------+
|       3       |     3     |    /boot    |    ext4     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     5     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |       bios_grub       |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |             |    ext4     |         boot          |
|               +-----------+-------------+-------------+-----------------------+
|       4       |     3     |    /boot    |    ext4     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     5     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |       bios_grub       |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |             |    ntfs     |         boot          |
|               +-----------+-------------+-------------+-----------------------+
|       5       |     3     |    /boot    |    ext4     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     5     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |       bios_grub       |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |             |    ntfs     |   boot legacy_boot    |
|               +-----------+-------------+-------------+-----------------------+
|       6       |     3     |    /boot    |    ext4     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     5     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+
|               |     1     |             |  biosgrub   |       bios_grub       |
|               +-----------+-------------+-------------+-----------------------+
|               |     2     |             |    fat32    |   boot legacy_boot    |
|               +-----------+-------------+-------------+-----------------------+
|       7       |     3     |    /boot    |    ext4     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     4     |             |    swap     |                       |
|               +-----------+-------------+-------------+-----------------------+
|               |     5     |      /      |    ext4     |                       |
+---------------+-----------+-------------+-------------+-----------------------+

Someone (not on here) suggested wiping the entire drive. I did so using "sudo dd if=/dev/zero of=/dev/sdb". I then set the drive to use GPT. I tried installing Ubuntu and I am having the same issue as the previous attempt.

http://paste.ubuntu.com/24009927/

31
  • What OS is already installed (in the main drive)? If Windows then most likely in UEFI mode. If Ubuntu was correctly installed in the same mode you always be booting from the first drive, the one that contains the ESP (EFI System Partition). – user589808 Feb 3 '17 at 3:26
  • 3
    Your 4TB drive must be gpt partitioned. That normally is for UEFI, but with Ubuntu you can install in BIOS boot mode with a bios_grub partition. I add both the ESP - efi system partition for UEFI boot even if not now needing it as inserting it at beginning of drive is difficult once drive has lots of data. If Windows is in BIOS boot mode you must install Ubuntu in BIOS boot mode as you do not have an ESP on sda (Windows drive). So UEFI grub will not install. askubuntu.com/questions/743095/… & help.ubuntu.com/community/DiskSpace – oldfred Feb 3 '17 at 17:08
  • 1
    Just use gparted to add the bios_grub partition. It can be anywhere on drive, must be unformatted, only needs to be 1 or 2MB and must have bios_grub flag for grub to be able to install to protective MBR on gpt partitioned drives. Do not install grub to a partition like you have shown as BIOS only boots from MBR. If you add bios_grub and do a full uninstall/reinstall of grub in BIOS mode, your system will boot from sdc.help.ubuntu.com/community/DiskSpace – oldfred Feb 7 '17 at 23:28
  • 1
    You always select a drive to install grub into. But with MBR grub is in MBR, but core.img is in the sectors just after the MBR. But with gpt partitioning the gpt has no sectors after the MBR available. So for grub to install its core.img, it must have the bios_grub. Otherwise grub does not correctly install with BIOS boot on gpt partitioned drive. You can always install grub to another MBR on a MBR(msdos) partitioned drive as MBR partitioning has the space, but then both drives have to be present to boot. Why do you not want the bios_grub partition? It is only 1 or 2MB. – oldfred Feb 8 '17 at 20:49
  • 1
    The gpt protective MBR says core.img not found at location. It should be at first sector of bios_grub or 6,790,035,456. Run the suggested fix by Boot-Repair. It also says Secure boot may be on. Make sure it is off as BIOS/CSM is not Secure Boot. – oldfred Feb 9 '17 at 5:12
2

According to oldfred from his post post above, the 4 tb hard drive must be GPT partitioned. This is actually incorrect. If the OP partitions the 4 tb hard drive as two 2 terabyte hard drives, then he can access them as MBR partition. https://superuser.com/questions/368173/what-is-the-maximum-number-of-partitions-that-can-be-made-on-a-hard-drive

Also, read this https://superuser.com/questions/562331/mbr-partition-with-more-than-2-tb

1
1

Forgive me if I missed something in the discussion, but did you try putting the grub-bios partition first? I see it second, but still 3T into the disk. Try the below GPT partitioning:

  1. 2M grub-bios flag
  2. 500M future EFI partition (easier than trying to move partitions later.
  3. 500M /boot partition. So the kernels don't wind up 3T into the disk.
  4. The rest, ntfs, swap, and ext4 root.

    You can try the above, if it works, try without the /boot -- those usually cause trouble when full because you have too many old kernels, but they used to be necessary for BIOS limitations on addressing, which maybe we're seeing again with the big disks.

I use a legacy Win10 main disk, but have a GPT second disk, to which I did a legacy install, and later added UEFI boot capability by populating the ESP on the second disk. Things to check, that you can actually boot from the sdc disk.


A 1M size for the bios-grub would be sufficient, but then maybe the 2M suggestion is to keep alignment. Check your disk mfg recommendations. Consider the ESP planning for the future, or someone's (arbitrary) decision that UEFI is the way to go. Make it smaller if space is an issue, Ubuntu's bootloaders can fix in 6m, including a backup copy in /EFI/Boot. You don't have to set anything up, just allocate the partition, and leave it empty.

6
  • Thanks for the suggestion. I'll give it a try when I get the chance and let you know how it goes. I probably won't set aside the EFI partition since I don't think we will ever need it. As stated in the original post, the Windows side is maintained by the University's IT department and they use legacy boot. From what I have heard from oldfred, trying to use both legacy boot and EFI would make things even more complicated. From other things I have read online, I'll probably shrink the bios_grub to 1MB. – Andrew Shum Feb 12 '17 at 23:19
  • Thanks for the update. The 2MB size for bios-grub was only a suggested upper limit by oldfred. I did that to ensure that there was enough space. From what I am seeing online, the common suggested size is 1MB. From previous experience with other hard drives (both this manufacturer and others), the 1MB alignment requirement implemented by most GUI partitioning programs is sufficient to keep the drive working without any issues. – Andrew Shum Feb 13 '17 at 19:55
  • there are a few BIOS that will not boot without boot flag. And with gpt the only partition that is supposed to have boot flag is the ESP. I normally with all gpt drives add both an ESP for UEFI boot and a bios_grub for BIOS boot as first two partitions. If not ever using UEFI, you can make a tiny FAT32 formatted partition with boot flag. If drive may later be used with UEFI, make an ESP that is 300 to 500MB. UEFI suggests it be first, but Windows often makes it second or third partition, but not far into drive. – oldfred Feb 13 '17 at 21:07
  • I have updated my OP with the results. I am afraid that Boot-Info appears to see nothing wrong but it still won't boot. – Andrew Shum Feb 13 '17 at 21:09
  • @oldfred We commented at about the same time so I only just saw your comment. I will try adding the boot flag. – Andrew Shum Feb 13 '17 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.