0

I have a intel wireless 7260ac card in my laptop which used to get 300Mb but now only gets 54Mb I see that it shows up as a IEEE 802.11abg after the resent ubuntu 16.04.1 upgrade how can I fix this?

I type the command sudo lshw -C network

 *-network               
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 73
       serial: 0c:8b:fd:4e:64:8e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-62-generic firmware=17.352738.0 ip=192.168.1.10 latency=0 link=yes multicast=yes wireless=IEEE 802.11abg
       resources: irq:31 memory:f7d00000-f7d01fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.2
       bus info: pci@0000:04:00.2
       logical name: enp4s0f2
       version: 0a
       serial: 00:90:f5:f9:d9:f8
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8411-1_0.0.3 06/18/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:27 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

I also did a check of my signal strength which is good using nmcli d wifi

*  SSID                             MODE   CHAN  RATE       SIGNAL  BARS  SECURITY 
   guest_2.4ghz                Infra  7     54 Mbit/s  89      ▂▄▆█  WPA2     
*  2.4ghz                      Infra  7     54 Mbit/s  77      ▂▄▆_  WPA2     
   5ghz                        Infra  161   54 Mbit/s  77      ▂▄▆_  WPA2  

I also did a uname -a

Linux sys76 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I also did a lsb_release -a

LSB Version:    core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial

I did a iwconfig using iwconfig wlp3s0

wlp3s0    IEEE 802.11abg  ESSID:"2.4ghz"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: E0:3F:49:93:3F:10   
          Bit Rate=54 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:134   Missed beacon:0

I did a ls /lib/firmware | grep 7260

user1@sys76:~$ ls /lib/firmware | grep 7260
iwlwifi-7260-10.ucode
iwlwifi-7260-12.ucode
iwlwifi-7260-13.ucode
iwlwifi-7260-16.ucode
iwlwifi-7260-17.ucode
iwlwifi-7260-7.ucode
iwlwifi-7260-8.ucode
iwlwifi-7260-9.ucode
  • 1
    Please post dmesg | grep 7260 to pastebin and post the link here. For the syntax, pick "Bash Session". And another for iwlwifi. – ThisIsNotAnId Feb 2 '17 at 21:56
1

Found the issue I had the line options iwlwifi 11n_disable=1 added to my /etc/modprobe.d/iwlwifi.conf file to which fixed another problem with disconnecting so I took this out and it fixed the speed problem. But I'm having to many problems with my wifi card and network-manager disconnecting and decided to try wicd.

Also added the line (to turn of wifi power management)

sleep 5 ; /sbin/iw wlp3s0 set power_save off

to my /etc/rc.local file

Updated Answer:

Updating this answer because ran into more problems and disconnects Here's a list of final changes that seem to be working.

1) Upgraded to to kernel 4.8.0-39 from 4.4 
2) Added files 
     -/etc/modprobe.d/iwldvm.conf
      added line: options iwldvm power_scheme=1

     -/etc/modprobe.d/iwlmvm.conf
      added line: options iwlmvm power_scheme=1

     -/etc/modprobe.d/iwlwifi.conf
      added line: options iwlwifi power_save=0
      added line: options iwlwifi 11n_disable=8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.