4

This is really frustrating as I just bought my asus USB-AC68 and I cannot seem to find the right drivers for this one! Help would be appreciated as I've been looking around for hours now... Lsusb command returns ID 0b05:1817 for my wifi usb (as it is the only Asusteks in the list...)

EDIT: Running ubuntu 16.04

Thanks!...

3

3 Answers 3

5

I found some driver that should work. I forked the driver from https://github.com/diederikdehaas/rtl8814AU.git and added the dkms.conf there. I've sent a pull request to diederikdehaas too.

Run in a terminal

sudo apt install git build-essential dkms
git clone https://github.com/hanipouspilot/rtl8814AU.git
sudo dkms add ./rtl8814AU
sudo dkms install rtl8814AU/4.3.21

The driver has your IDs.

If you install the driver this way, it will stay after kernel upgrades.

5
  • 1
    I have used this (and the above method) to install the drivers in Ubuntu 16.04, and it has worked each time. I have to do it again every now and then, and so was wondering if you could tell me which actions of mine would cause these settings to be lost or reset? The only idea I have it when tweaking things in the BIOS, otherwise I haven't done anything drastic.
    – n1k31t4
    Mar 31, 2017 at 10:59
  • Hello, thank you for the post! Could you please tell, if this solution works with the latest LTS version of Ubuntu? I'm thinking about buying this device. Oct 21, 2019 at 12:18
  • I am not sure if it builds for new kernels. But it is not hard to fix it, or find another repo.
    – Pilot6
    Oct 21, 2019 at 14:17
  • will this work for the newer AC1900 usb-ac68 wifi adapter? Also is there any harm in trying many of the solutions on the web? Sep 15, 2020 at 17:18
  • I guess not, I got: sud o dkms install rtl8814AU/4.3.21 Kernel preparation unnecessary for this kernel. Skipping... Building module: cleaning build area... 'make'...(bad exit status: 2) ERROR (dkms apport): binary package for rtl8814AU: 4.3.21 not found Error! Bad return status for module build on kernel: 5.4.0-45-generic (x86_64) Consult /var/lib/dkms/rtl8814AU/4.3.21/build/make.log for more information. Sep 15, 2020 at 17:21
3

I just got this thing in the mail today. Bought it because someone in the comments said "plugged it in to linux and it worked right out of the box. Definitely not true. soo... tried Pilot6's solution, but it didn't work for me. Spent the last few hours digging. Long story short, found this other project by the same guy on github https://github.com/diederikdehaas/rtl8814AU

Here's what I did. Maybe someone smarter than me can fix my syntax if I'm not being very efficient...

git clone -b driver-4.3.21 https://github.com/diederikdehaas/rtl8814AU.git
cd rtl8814AU
sudo make && sudo make install

output of make install

install -p -m 644 8814au.ko  /lib/modules/4.4.0-59-generic/kernel/drivers/net/wireless/
/sbin/depmod -a 4.4.0-59-generic

So I ran

sudo modprobe -v 8814au

and got the below

insmod /lib/modules/4.4.0-59-generic/kernel/drivers/net/wireless/8814au.ko 

DMESG shows this

[4188.649295] rtl8814au 3-2.4.3:1.0 wlx2c4d5404a218: renamed from wlan

at this point I clicked the panel wifi icon and had two adapters. turned off the internal one (laptop) and connected with the new one. The adapter name was blank when typing in the password. Just ran speedtest.net and pulled 188 down and 53 up (Mbps). Was pulling about 45 down and 15 up before the new adapter. Hope this helps!

6
  • It is better to install with DKMS. Otherwise you will need to re-install after each kernel upgrade. I will update my answer.
    – Pilot6
    Feb 3, 2017 at 9:13
  • Forget it, kept typing the wrong password... But now it works! Thanks guys! Feb 3, 2017 at 15:50
  • Just so you are aware: I had kernel 4.4.0-724-generic and suddenly the driver wasn't working anymore. the latest kernel that works with this driver is 4.4.0-72-generic
    – SomeOne01
    Apr 18, 2017 at 21:06
  • /media/nobu/UbuntuFiles/Downloads/rtl8814AU/include/osdep_service_linux.h:273:8: error: ‘_timer {aka struct timer_list}’ has no member named ‘data’ ptimer->data = (unsigned long)cntx; ^~ /media/nobu/UbuntuFiles/Downloads/rtl8814AU/include/osdep_service_linux.h:274:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration] init_timer(ptimer); ^~~~~~~~~~ _init_timer Sep 15, 2020 at 16:49
  • github.com/aircrack-ng/rtl8812au seems better maintained Feb 22, 2021 at 0:45
1

This worked on Ubuntu 18.04 LTS: https://github.com/aircrack-ng/rtl8812au

On a good eduroam WiFi network, I was getting speeds over 100 Mbps.

But I've upgraded to 20.04, after reinstalling 18.04 after I accidentally deleted and overwrote my home directory, and trying to install it now so I'll update this answer soon.

Not the answer you're looking for? Browse other questions tagged or ask your own question.