I use KDE in Ubuntu 11.10 (I installed KDE with kubuntu-desktop using software center), which comes with muon package manager bundled, but some day Muon package manager decided not to update and giving an excuse 'that other package manager is already running'.

Another application seems to be using the package system at this time. You must close all other package managers before you will be able to install or remove any packages

I open krunner, nothing that is related with package managment is running as I can see in the processes running.

I did everthing what is posted here: http://kubuntuforums.net/forums/index.php?action=printpage;topic=3119344.0

And muon-updater/muon package manager refuses to install any updates.

I can install/uninstall with aptitude, apt-get with no error notifications, I can even upgrade packages with gnome's update manager, but that's not my case.

I don't have broken packages, as 'aptitude' doesn't tell me nothing about broken packages, neither muon, neither apt-get.

What else can I do in order to get muon installing/upgrading packages as usual?.

As Additional info: I upgraded KDE 4.7.2 to 4.7.3 through kubuntu-updates PPA, and I have 202 packages to upgrade but aptitude says that won't upgrade many packages because the upgrading will broke dependencies, that in every upgradeable package listed in aptitude.

I made in Konsole sudo apt-get update && sudo apt-get upgrade then it list the 204 packages that will upgrade but in the end says 204 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 161 MB of files. It used 233 kB of additional disk space after this operation. Do you want to continue [Y / n]? I translated the apt-get message using google, this is the original in my native language: 204 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados. Necesito descargar 161 MB de archivos. Se utilizarán 233 kB de espacio de disco adicional después de esta operación. ¿Desea continuar [S/n]?

this last might be the reason why muon can't upgrade anything?.

  • if still doesnt work... you know what to do :P – user47648 Feb 23 '12 at 3:29

I solved it. I made the upgrade of all packages with sudo apt-get upgrade inside Terminal (Konsole), it donwloaded the packages, installed them, and configured them. After that upgrade muon (package manager and software center) is capable to install and remove packages, nevertheless I need to see if this issue repeats again, but for now this question is solved. Thanks.

That upgrade of 202 packages was the upgrade of KDE platform version 4.7.3 to 4.7.4.


After closing Muon you should verify that no apt and dpkg processes are still running. In a terminal, enter ps -efl | egrep 'apt|dpkg' to list possible suspects. then use kill -9 nnnn to stop them and try running apt-get again.


If this doesn't help, you should check if there is a lock file in one of the directories Muon accesses.

Check /var/lib/dpkg/lock, then look in the /var/cache/apt/archives/ directory, ...

  • It didin't work either, I found that /usr/share/apt-xapian-index/update-apt-xapian-index-dbus was running, I killed it with kill -9, then I opened muon and with same result. muon still thinks that there's other package manager open and is not. – Jose Luis Dec 15 '11 at 21:23

Your problem seems to be described here. Please try the advice in comment#1.

  • It didn't worked, muon still gives me the excuse that other package manager is running and is not, after the box message muon keeps working in second plane forever until I close, but then it creates the lock archive. I think that something runs when I enter session but never finishes it tasks, that why I have the lock archives and muon can't do nothing. – Jose Luis Dec 15 '11 at 15:53

Try only this:

sudo dpkg --configure -a


sudo fuser -vki
/var/lib/dpkg/lock;sudo dpkg --configure -a

heres what i did,

do sudo apt-get upgrade

and if it doesnt work do what it tells you to which should be something like

sudo dpkg --configure -a

then you can do

sudo apt-get upgrade

then just go to the muon package manager and do all the updates.

well thats what worked for me.


First, close Muon.

sudo dpkg --configure -a

If that doesn't work:

sudo killall dpkg

If that still doesn't work, log out and log back in.

protected by Community May 17 '12 at 9:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.