1

Running Ubuntu 16.04 with Unity.

When I hit Ctrl+Alt+Delete I get a System Monitor instead of the logout screen.

In my System Settings > Keyboard > Shortcuts > System, under "Log out" it says Ctrl + Alt + Delete.

Any idea how I get this to work? I have Unity Tweak Tool and Tweak Tool installed, but I can't find anything in there that might be overriding this setting.

How can I get my log out screen back with Ctrl+Alt+Delete?

0

If you're willing, Switchboard has an excellent keyboard shortcut configurator built-in.

Switchboard is the "System Settings" app for Elementary OS. You can get the source at the link below and compile for your system according to the instructions in the "INSTALL" file once you extract the archive:

https://launchpad.net/switchboard/+download

IMPORTANT

Make sure you have all the dependencies they list in the install file installed before running any of those commands.

ALTERNATIVELY, you may opt to simply install it from the elementary ppa:

sudo add-apt-repository ppa:elementary-os/stable
sudo apt-get update
sudo apt-get install switchboard

Open a terminal and run whoami. Let the output to this command be denoted <user>

Once installed, navigate to the "Keyboards" section. Then under shortcuts, click on custom enter pkill -KILL -u <user> by typing it out (no copy and paste) and pressing ENTER.

It will be disabled by default. Click on disabled and then just press the key combination you want to use.

WARNING

I'm not sure if this method will ensure all your work is saved before logging you out. So please look into this before using it, maybe ask another question here for that.

Although, I'm not sure just clicking on Log Out on the panel ensures your work is saved either...

For more information on this process, see:

https://www.cyberciti.biz/faq/linux-logout-user-howto/

and

https://www.cyberciti.biz/tips/howto-linux-kill-and-logout-users.html

0

Look in your custom shortcuts and see if Ctrl + Alt + Delete is set there. If it is, it very well might give priority to the custom shortcut. If you have the CompizConfig Settings Manager, it might also be set there (you can just run ccsm in the terminal or search for it in the dash).

If you can't find it, you might just want to set a different key combination to lock the screen. I use Super + L so it's the same on both Ubuntu and Windows.

  • no ccsm installed. Oddly enough, Super + L DOES bring up my lock screen. – 43Tesseracts Feb 2 '17 at 19:22
  • Custom shortcut keys are empty. – 43Tesseracts Feb 2 '17 at 19:23
  • Super + L locks my screen too. I think it's a default. – WinEunuuchs2Unix Feb 2 '17 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.