1

I'm not able to access or open KDE connect indicator. Whereas kde connect monitor and kde connect settings are opening. What should I do?

  • Do you have both the following packages installed? kdeconnect, indicator-kdeconnect? On a terminal run dpkg -l indicator-kdeconnect kdeconnect and tell us what two letters are written on the left of their names in the output. For example, if installed the letters should be "ii". – ThisIsNotAnId Feb 2 '17 at 16:19
  • Yeah they are installed – freeezer98 Feb 2 '17 at 16:22
  • Try running sudo apt-get purge indicator-kdeconnect, sudo apt-get purge kdeconnect. Log out, log in. Re-install both from synaptic package manager or by running sudo apt-get install kdeconnect indicator-kdeconnect. Tell us if this helps. – ThisIsNotAnId Feb 2 '17 at 16:24
  • When I installed indicator-kdeconnect I noticed that it didn't show up in the system tray till I restarted the computer and re-opened the indicator applet. So if the above doesn't work, try this too. – ThisIsNotAnId Feb 2 '17 at 16:28
  • I checked the first one and found the output ii ; and dkpg-query: no packages found matching indicator-kdeconnect – freeezer98 Feb 2 '17 at 16:30
2

Try unpair and start over, but make sure you request pair from the desktop app to the phone and not the other way around.

Also, verify that the phone is:

  • On
  • Connected to same WiFi as your Ubuntu device.

Otherwise, there could be something wrong. In this case you can consider reinstalling kde-connect as suggested by @ThisIsNotAnId:

sudo apt purge indicator-kdeconnect kdeconnect
sudo apt install indicator-kdeconnect kdeconnect
| improve this answer | |
  • Ah... I'm missing the point. – Liso Feb 2 '17 at 16:42
  • Tried unpair and re connecting & reinstall but the same only kdeconnect settings and kdeconnect monitor are opening. Kdeconnect indicator keeps closing even before start. – freeezer98 Feb 2 '17 at 16:48
  • The steps you mentioned about pairing are important. I think I noticed the same problem running the kdeconnect the first time. – ThisIsNotAnId Feb 2 '17 at 16:50
0

Following our discussion in the comments, it seems you don't have the necessary repo on your system for indicator-kdeconnect. Run the following on a terminal:

sudo add-apt-repository ppa:vikoadi/ppa
sudo apt-get update
sudo apt-get install indicator-kdeconnect

Log out, log in. Open indicator applet.

===EDIT===

Open a terminal and run indicator-kdeconnect and post any messages, errors, warnings that the terminal gives in your question.

| improve this answer | |
  • No luck. Not opening. Tried exactly the same commands and procedure. – freeezer98 Feb 2 '17 at 17:20
  • @user648595 I think there may be broken packages on your system. I'm not sure what the problem might be. It could be the DE you're using. I don't know what environments other than unity 16.04 ships with. But if you have another DE installed can you login to that environment and try opening again? If you don't know how to change the DE look at this answer and see if you have something similar: askubuntu.com/a/400581/45639 If this doesn't work out, you might want to consider asking a question here about unity, installing another DE (try Budgie), or re-installing unity (not recommended). – ThisIsNotAnId Feb 2 '17 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.