1

SPECS HP laptop - 13 inch 13-a201tu Ubuntu Gnome 16.10 running Gnome Wayland.

My HP laptop ( 13-a201tu) is a 13 inch two in one convertible x360. it was updated in bios from F.24 to F.35 and since then everything hs gone downhill. I was dual booting Arch Linux (Apricity ) and Windows 10. since updating the bios, booting Linux (later reformated hard drive with only ubuntu) gave blank screen, and from legacy mode, I saw the problem. Sleep / Resume not supported by ACPI. so I put in kernel options

    acpi_backlight=vendor acpi_osi="!Windows 2009" acpi_osi="!Windows 2012" acpi_osi="!Windows 2013" acpi_osi="Linux" acpi_osi=Linux

The problem was, that now after I extracted the DSDT table of this new bios (to see what all OS versions were detected, so I knew what to disable/enable) I still got a recurring battery problem.

EXAMPLE - battery is actually charged 100%, but while my laptop was on, so when I disconnect the charger, suddenly charge becomes 9%, then goes down to 1% and stays there for 4 hours. then because of critical battery option, Gnome Ubuntu shuts down thinking battery low when the battery is actually close to 30 %. so downgrading bios is almost impossible (even HP service center couldn't do it) but two options remain.

  1. try to solve why this is happening, maybe extract the original dsdt from F.24 bios, and replace file.
  2. disable ubuntu from knowing the battery exists

the third option was to disable critial battery action and Upower.conf but, even then, the notifications are annoying, and the fan randomly starts running high. any help would be appreciated. thank you.

  • Why do you have all of these acpi_osi kernel parameters, and even the last one which is a duplicate of the one right before it? You only need one, and maybe not even that. To strip away all of the mods that it sounds like you've made to your OS, try booting the Ubuntu Live DVD and see if you see the same problems. – heynnema Feb 3 '17 at 0:48
  • 1. i actually decompiled the DSDT table of the bios and saw that it checks the os like this.. if os = linux, then code xyz else if os = winp-not-key, then code xyz else if os = windows 2009 then code xyz else if os = windows 2012, then code xyz else if os = windows 2013, then code xyz 2. thats true, the last ACPI_osi command is a duplicate :P – Ubuntu NutCracker Feb 4 '17 at 9:33
  • 3. no, i DONT need one (i guess) because i tryed the live cd (how else would i install ubuntu after the bios update?) and blackcreen... i tryed each osi seperately, didnt work. on top of that, i need acpi_backlight=vendor otherwise brightness isn't changable. – Ubuntu NutCracker Feb 4 '17 at 9:38
  • 4. i tryed doing that , and the result was a black screen, but if i did the same in CSM (legacy bios) in big bold letters was written about 10 times, SYSTEM WAKEUP DISABLED BY ACPI. and even after all of this, i saw in the logs app of gnome 3, in hardware section, the same message, but this time it was displaying the pci device, so using a terminal command i dont remember, i enabled the wakeup in the specified pci devices. – Ubuntu NutCracker Feb 4 '17 at 9:41
  • Please review askubuntu.com/questions/186296/… and try some of the parameters there when booting the Ubuntu Live DVD... like acpi=off or nomodeset. – heynnema Feb 4 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.