36

I sometimes have the problem that I can't hear any sound on my Dell XPS13 with Ubuntu 16.04. I have a Logitech G930 connected to it. When I open pavucontrol it is stuck at "Establishing connection to PulseAudio. Please wait..." I have been following the Ubuntu Audio Problems Guide (german version is here: https://wiki.ubuntuusers.de/Sound_Problembehebung/#Soundsystem ) and found the following:

$ cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0xdc428000 irq 295
1 [H              ]: USB-Audio - Logitech G933 Gaming Wireless H
                     Logitech Logitech G933 Gaming Wireless H at usb->0000:00:14.0-1, full speed

So the sound cards are recognized. However, audio is not played:

$ aplay /usr/share/sounds/alsa/Front_Center.wav 
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied
aplay: main:722: audio open error: Connection refused

Same with sudo:

$ sudo aplay /usr/share/sounds/alsa/Front_Center.wav
Home directory not accessible: Permission denied
Home directory not accessible: Permission denied
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit >Little Endian, Rate 48000 Hz, Mono

The "groups" command does NOT show the audio group, but what I think is strange that it works most of the time (and often so after restarting, if there are problems) so I'd guess it's not the problem.

Where else could I look?

Edit:

$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9d71]     (rev 
21)
Subsystem: Dell Device [1028:075b]
Kernel driver in use: snd_hda_intel



$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: H [Logitech G933 Gaming Wireless H], device 0: USB Audio     [USB >Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


$ pactl list short sinks
Connection failure: Access denied
5
  • We should not be in the audio group, and we should not run audio apps as root. Sometimes deleting poor settings in our HOME need to be deleted. See askubuntu.com/questions/201780/…
    – Takkat
    Commented Feb 2, 2017 at 13:47
  • Could you please edit your question to include the output of the terminal commands lspci -nnk | grep -A2 Audio, aplay -l, and pactl list short sinks? If PulseAudio (via pactl) doesn't respond, please (back up and) remove ~/.pulse, start PulseAudio (pulseaudio --start) and try again. Thanks. Commented Feb 2, 2017 at 14:00
  • Sorry, took me a while to reproduce the error and have the time to write everything down. I have edited the question. I have not found a file at ~/.pulse
    – Bernie
    Commented Feb 7, 2017 at 11:10
  • Hey @Bernie, did you ever got to fix this? Facing the exact same issue..
    – Asitis
    Commented Jul 4, 2018 at 14:27
  • Maybe the files are in ~/.config/pulse instead of ~/.pulse. At least on OpenSuSE they are...
    – rwst
    Commented Dec 12, 2018 at 7:52

7 Answers 7

27

This solve the same problem with my:

pulseaudio --check
pulseaudio -D

Taken from: [Solved] Establishing connection to PulseAudio. Please wait ... https://classicforum.manjaro.org/index.php?topic=27044.0

17

I've had this issue since upgrading to 18.04 and read almost all there is about to read about it. I fiddled with the settings, the packages, and eventually it would work sometimes, after installing PulseEffects for getting the right channel throughput for the audio. But then when I would change the audio-output channel to say headphones instead of speakers, the gnome shell crashed. This crash gave me insight to some "obsolete packages" that were still installed and needed removing or upgrading.

So in summary, running these commands solved all my audio problems after a few weeks of debugging (so stupid if you see it now, but whatever works right?)

sudo apt-get update
sudo apt-get upgrade
sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio pavucontrol
sudo alsa force-reload
reboot

Then

sudo add-apt-repository ppa:mikhailnov/pulseeffects
sudo apt-get update
sudo apt-get install pulseeffects

After a final resetting of the audio output channel, it worked like a charm again.

7
  • 3
    I followed everything mentioned above except the last command which gave me an error saying -- unable to locate package pulseeffects.. Then i did 'pulseaudio --start' and audio started working again.
    – Aseem
    Commented Dec 13, 2018 at 12:06
  • Also got that error and the penultimate command essentially said "nothing to be done" i.e. pavucontrol is already the newest version (3.0-4) and it removed alsamixer Commented Dec 28, 2018 at 18:48
  • Thank you! This worked for 18.10 as well.
    – Don
    Commented Jan 23, 2019 at 4:00
  • Thank you so much for this answer, I have been trying to solve this issue for a month on 18.10 (new install, not upgrade) after my sound randomly crashed when I was trying to record on audacity. The pulseeffects step wasn't necessary, but like Aseem I needed to do 'pulseaudio --start'
    – rjb-dev
    Commented Apr 28, 2019 at 6:31
  • sudo apt-get install pulseeffects return error "Unable to locate package pulseeffects" to fix that you need to instll by sudo add-apt-repository ppa:mikhailnov/pulseeffects and then sudo apt update and finally sudo apt install pulseaudio pulseeffects --install-recommends Commented Feb 12, 2020 at 2:37
10

I solved this issue by deleting ~/.config/pulse followed by a reboot.

4
  • 4
    +1 I did something similar, which may help with debugging as it doesn't require a reboot: mv ~/.config/pulse ~/.config/pulse.old followed by pulseaudio --start
    – FriendFX
    Commented Feb 12, 2020 at 2:34
  • 1
    Running Arch Linux and this resolved my issue on i3
    – Ari
    Commented Aug 30, 2020 at 5:44
  • 3
    great! removing it and issueing pulseaudio --start did the trick. (Linux Mint 20)
    – umbe1987
    Commented Dec 16, 2020 at 16:07
  • 1
    Damn!!! πŸ‘ΊπŸ‘ΊπŸ‘Ί I should had started my research with this one, instead of spending a eon trying complex solutions out πŸ˜–πŸ˜–πŸ˜– Commented Jul 17, 2021 at 5:34
1

systemctl --user restart pulseaudio.service

I found this one on internet and this also work for me. ha ha ha.

0
1

I have tried every possible solution from everywhere to get the sound working through HDMI on NUC11PAHi7 on Ubuntu 22.04.1 LTS after it stopped working, including the solutions in this thread and none worked. What ended up working is doing the screen lock with windows key L, waiting a minute and then unlocking it. I could not believe it. Hours in terminal trying everything and just locking and unlocking the screen fixed it. I found that answer in a different thread about trying to find realtek drivers for NUC on ubuntu, and now I can't find that thread again to thank them.

0

For me, this issue was being caused by the fact that the UID folder for my user wasnt generated in /run/user/, you can check the UID of your user with id -u. I solved it by logging into my user through a TTY, I'm sure theres a better way to solve this though.

This issue was also preventing me from starting up blueman-applet & blueman-manager

0
pulseaudio -k
pulseaudio -v
sudo reboot 

it worked in my case

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .