14

I am attempting to transfer files from my OnePlus X Android phone to my fairly fresh Ubuntu 16.10 installation. After the phone is mounted (and I can see file, navigate the filesystem etc.), when I attempt to transfer files from the phone to the Ubuntu system, I am presented with the following error message:

libmtp error:  Could not get file from device.

What might be going wrong here? I have previously installed libmtpserver-dev and mtp-server.

5
  • Wich version of libtmp do you have?
    – M. Becerra
    Feb 2 '17 at 13:41
  • @M.Becerra Hey, I have libmtpserver-dev version 0.0.4+16.04.20160413-0ubuntu4 and mtp-server version 0.0.4+16.04.20160413-0ubuntu4.
    – d3pd
    Feb 2 '17 at 15:01
  • 2
    Interestingly, I got the same message when my local HDD was out of space. Misleading error message, but when I made some space all files copied without problems (Ubuntu 16.04.2)
    – n3rd
    Aug 17 '17 at 15:10
  • I ran into this issue when transferring a large amount of photos from a phone before retiring it. One quick workaround I came up with was to first first put the files in an archive on the phone. For this I used the app ES File Explorer. I used zip as format but with compression set to store. Then I just transferred that archive instead.
    – Clox
    Jun 25 '18 at 7:30
  • use a usb port without a hub
    – tronic
    Aug 22 '19 at 14:07
8
  1. Install this dependency to build libmtp

    sudo apt-get install libusb-dev --install-suggests

  2. Get the libmtp here libmtp Latest Download

  3. Extract the file using a file explorer program [or via the terminal]

    tar xvf libmtp-1.1.1.tar.gz

  4. cd into the new directory you just extracted
  5. Configure (MAKE SURE YOU'RE ARE IN THE /libmtp-*/ DIR)

    ./configure --prefix=/usr make

  6. Install (AGAIN, MAKE SURE YOU'RE IN THE /libmtp-*/ DIR)

    sudo make install

  7. Copy rules to /etc/udev/rules.d/ (you might wanna double check the rules.d/ dir to see if coping over the new set of rules is necessary ... it probably is)

    sudo cp 69-libmtp.rules /etc/udev/rules.d

  8. Install the gMTP GUI Util

    sudo apt-get install gmtp --install-suggests

  9. Open/Run the gmtp program from the menu or term and enjoy!

NOTE: If you have issues you might need to disconnect the device. Or restart. Or update things... sudo apt-get update and/or sudo apt-get upgrade

Hope this helps, if so vote up. If more help is needed hit me up and I'll do what I can.

7
  • 1
    I'm on Ubuntu 16.04 and can confirm this works! thanks!
    – 9a3eedi
    Oct 2 '17 at 5:45
  • I tried this on my oneplus 3T Ubuntu 16.10 but gmpt says no device connected. When I do connect my oneplus 3T the CD mounts however but I cannot access the internal storage via file manager or gmtp. Thanks
    – twiz911
    Oct 9 '17 at 5:01
  • @user894199 That sounds odd. Sorry, I wish I had some insight to help you out but I'm not sure what to do in your case. Mar 16 '18 at 22:20
  • On 16.04, have similar problem to Clox's. While transferring files with Nautilus, the transfer gets interrupted randomly with the error message in this topic. Steps from Anovative here worked for installing gmtp and might have helped Nautilus stay connected long enough to transfer some 1GB and larger files, which I could not do before following these steps. The gmtp program also got successfully installed, but cannot connect to the phone. When I click the connect button, Nautilus seems to take over and connect instead, and gmtp errors with "Detect: No available Storage found on device?" Jul 29 '18 at 15:58
  • In fresh Ubuntu, got this 'no acceptable C compiler' (gcc was not installed), so did this before building libmtp -> 'sudo apt-get install build-essential'. Mar 14 '19 at 17:09
0

@Anovative's answer is what worked for me.

New LG G6 would not mount properly on Ubuntu 14.04.5. It half-worked; I could navigate the file structure in my phone. Retrieving files didn't work though.

Error details were often:

libmtp error: call to ptp_mtp_getobjectpropssupported() failed

or

libmtp error:  Could not get file from device

Downloaded libmtp-1.1.14, compiled, installed the shared library, had to move things around a bit so the new .so was pointed at, now everything works just fine.

0

I wanted to transfer photos, and had to switch usb connection mode from file to photo on my phone (Android 10).

Not the answer you're looking for? Browse other questions tagged or ask your own question.