2

I am really sick of the "Move to Dropbox" option in my right-click context menu. I have accidentally moved large files to Dropbox because of it many times. Is there any way to disable that option in the context menu? I am running xfce with Thunar on Ubuntu 16.04.

I have found many ways to do it on Windows and Macs, but not Linux.

  • Nik.

Here's a screenshot:

thunar context menu

  • Which "right-click context menu"? Is it in Thunar? I installed Thunar with --no-install-recommends and don't see that option. I too have Dropbox installed. Could you post an image of the context menu (and some surrounding area) so it's clear? – DK Bose Feb 2 '17 at 10:20
  • 1
    I've added it to the post – Nikhil Joshi Feb 2 '17 at 10:56
  • askubuntu.com/questions/337225/… suggests you'll need to edit the source code! – DK Bose Feb 2 '17 at 12:02
  • Well I installed Dropbox separately from Thunar... That implies that the Dropbox package changed the source code of Thunar, recompiled it, and reinstalled it? That seems unlikely. – Nikhil Joshi Feb 2 '17 at 12:18
  • I have no idea. All the best. – DK Bose Feb 2 '17 at 12:25
1

Well, I found a solution... it may not be the best solution, but it does work. It turns out that the dropbox context menu is a package called thunar-dropbox-plugin, which I installed to get dropbox. When I removed the package, it did remove the context menu option, but it also removed dropbox. However, on Dropbox's install on Linux page, it shows you how to install dropboxd without the package. So I looked in ~/.dropbox-dist (which apparently was not deleted when I uninstalled thunar-dropbox-plugin) and there was dropboxd. So I just added that to my autostart list and now it runs whenever I start a session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.