4

I always get this error when I attempt to install a package using apt-get. I would appreciate help. This seems a common problem with every other package, but I've never encountered a problem with the dpkg itself.

enter image description here

  • 2
    the apt-get -f install prompts the same message – muffin Feb 2 '17 at 4:45
  • Recover some backups of dpkg: sudo cp /var/backups/dpkg.status.0 /var/lib/dpkg/status – David your friend Feb 2 '17 at 7:00
  • 1
    Can't find a source to download version '1.17.5ubuntu5.4' of 'dpkg:amd64' – muffin Feb 2 '17 at 8:25
  • Please update & add output from command: cat /etc/apt/sources.list Have you tried using Synaptic/Aptitude to reinstall packages. – David your friend Feb 9 '17 at 4:01
2

Ubuntu dpkg recovery

Recover dpkg status file

cp /var/backups/dpkg.status.0 /var/lib/dpkg/status

Reinstall - dpkg

cd /var/cache/apt/archives/ dpkg --force-depends -i dpkg_*.deb

Reinstall - apt

cd /var/cache/apt/archives/ dpkg --force-depends -i apt_.deb dpkg --force-depends -i apt-utils_.deb apt-get update


Missing files in /var/lib/dpkg/info?

Use dpkg to list installed packages..

dpkg -l | grep ii

Reinstall from output using apt...

dpkg -l | grep ii | awk '{print "apt-get --reinstall -y install", $2}' > /tmp/reinstall

Now, install ucf which may be of importance to installation of kernel or others...

apt-get --reinstall install ucf


Source: http://staff.adams.edu/~cdmiller/posts/Ubuntu-dpkg-recovery/

  • 1
    it still has the same error despite all the commands listed. – muffin Feb 3 '17 at 1:19
  • 1
    "The package dpkg needs to be reinstalled, but I can't find an archive for it." >> exact error listed – muffin Feb 3 '17 at 1:19
1

I found a solution that worked for a user with a related problem...

sudo -i    
mkdir /tmp/dpkg    
cd /tmp/dpkg

#i386 version
wget https://launchpad.net/ubuntu/+archive/primary/+files/dpkg_1.18.4ubuntu1.1_i386.deb    

or

#amd64 version
wget https://launchpad.net/ubuntu/+archive/primary/+files/dpkg_1.18.4ubuntu1.1_amd64.deb    

ar x dpkg*.deb data.tar.gz    
tar xfvz data.tar.gz ./usr/bin/dpkg    
sudo cp ./usr/bin/dpkg /usr/bin/    
sudo apt-get update    
sudo apt-get install --reinstall dpkg

Source: https://askubuntu.com/a/474681/562148

  • 1
    the dpkg package is no longer valid i guess? the wget returns a not found – muffin Feb 2 '17 at 4:46
  • 1
    What does w/ mean to a learner, please use full english words and not short hands! – George Udosen Feb 2 '17 at 5:10
  • 1
    since you use wget to download the package to reinstall it, then you don't need to navigate to tmp where its stored temporary after installing it – Pavlos Theodorou Feb 2 '17 at 5:48
  • 1
    You're right, @George! My bad, friend! – David your friend Feb 2 '17 at 5:50
  • 2
    sudo apt-get install --reinstall dpkg >> gives me the same error because apt-get requires dpkg but then dpkg is the one i need to reinstall.. – muffin Feb 2 '17 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.