This question already has an answer here:

Whenever I switch my old Dell E520 on first thing in the morning it fails to boot into Ubuntu 16.04. It gets through bios to grub & beyond but will stop while trying to load the os. It finishes at a black screen. This seems a common problem & I've tried all the suggested solutions appropriate to my setup from the My computer boots to a black screen, what options do I have to fix it? thread, but none have worked for me.

What seems different from any other solution or discussion offered is that I have found a strange workaround: if I get to grub & run memtest for a minute then press esc to reboot, all is well! This works every time.

My questions are: Can anyone suggest why this works? Is there a solution that does not need my intervention at grub?

marked as duplicate by Pilot6, Eric Carvalho, Kevin Bowen, David Foerster, user68186 Feb 10 '17 at 15:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Could you please add a little more detail? What exactly did you try and what happened? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. (see How do I ask a good question?) – David Foerster Feb 3 '17 at 0:54

Add nomodeset to your grub commandline.

Edit your /etc/default/grub file.

Look for this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Append nomodeset to the line so it looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Now update your grub with:

$ sudo update-grub

Then reboot.

  • I have already tried that, & many other grub file alterations, but none have worked for me. – zhdeef Feb 1 '17 at 12:12

This is a thermal problem, but it's reversed from the usual heat issues. One of the connections in your system RAM slots is only making contact when the system has warmed up a bit -- as it'll do after one or more boot failures, or after running memtest for a short time. Try removing and reseating your RAM modules, and you'll probably find the wiping action of the contacts brings back reliable connection and resolves the problem.

  • This certainly fits the fault profile. I'll try it over the weekend & report back. Thanks. – zhdeef Feb 2 '17 at 11:30

This particular problem can also be caused by a bad kernel, usually a non-default kernel though. Hold down the Shift key when booting the computer to show the GRUB menu and from the GRUB menu select an older kernel. You can use Force version and Lock version in Synaptic package manager to boot a specific kernel version all the time.

What's tricky about this problem is that opening the BIOS/UEFI utility and waiting for two minutes before continuing to boot also solves the problem, so the computer behaves as if it needs additional time to warm up. However reverting back to a default kernel also sometimes solves the problem without needing to wait for the computer to warm up. It should also be noted that I have observed that reverting to a default kernel worked in a situation in which the black screen came immediately after the purple screen with five dots underneath the Ubuntu logo. The dots start to change color from white to orange and then the black screen appears and the computer freezes at the black screen while the CPU is still running.

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.