I have several linux & windows vms(vmware) running on windows 10 pro host, in vmware workstation 12.5.

All vms are configured the same way in workstation, but the Ubuntu vm is not discovered in "networks" on Windows, and I can not connect to it from host.

The vm has internet connection, but the same situation occurs inside the vm itself. I can see all the other network locations there( host + all the vms), but the Ubuntu vm itself doesn't seem to be registering on the local network.

I use NAT, and I want to be able to use this for all vm's. I can connect to the other vm's through hostname, but as I said I can find no trace of this vm through ip or hostname. I find it very strange that this vm can detect other locations but not register !?

I have tried cloning + reinstalling this OS.

The avahi/zeroconf packages do help with discovery of other locations, as I can see them only when the avahi-daemon package is installed.

Also there is something weird going on with vmware-tools/open-vm-tools when using this distro. Workstation doesn't seem to correctly identify the installed tools, as "vm meny" keeps showing "update vmware tools". I have tried both open-vm-tools & vmware-tools from workstation distro. I am sorry for providing potentially insufficient info, but I will have to update through this post.

DHCP is working, windows network adapter + vm adapters are set to dynamic IP & DNS.

Finally as I already said, EVERYTHING else is functional. I am connecting from Windows vm's to all other Linux vm's for cross-compiling by way of Visual Studio.

EDIT: Still the same problem. I have tried several suggestions and workarounds both from this forum and other places, but I am unable to establish contact with this vm from host or other vm's.

My Kernel IP routing table looks like this :

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    100    0        0 eth0     U     1000   0        0 eth0   U     100    0        0 eth0

Now I know is put there by zeroconf to patch my ip because there certainly are some problems. But what I am looking for is an answer to why Ubuntu 16.04 is interacting differently with NAT(networks in general actually), than say Mint Cinnamon ?

I have tried sooo many fixes out there, but I cannot ping my ubuntu guest from host, and I cannot connect to it from other network locations. The kernel ip routing table above is the one produced when I define /etc/network/interfaces file like this for dynamic routing:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

So, I tried the suggestion of defining /etc/network/interfaces file like this:

auto eth0
iface eth0 inet static

... and endless variations of this. The info I get from the VIRTUAL NETWORK EDITOR in vmware, and there are again ABSOLUTELY NO reason why the fault should be anywhere else but in the Ubuntu OS, as all the other vms use the same setup.

There apparently seem to be differences in the implementation of AVAHI & ZEROCONF in Ubuntu 16.04 and say Mint Cinnamon 17.3 or SuperX 3.0. So what's the deal ? What can I say ? i tried modifying the /etc/nsswitch.conf value of host parameterto :

hosts:          files mdns4_minimal [NOTFOUND=return] dns

, tried to modify the /etc/avahi/avahi-daemon.conf to :


, modify the /etc/default/grub file:

GRUB_CMDLINE_LINUX_DEFAULT="net.ifnames=0 biosdevname=0"

I also tried to add a hostname in the /etc/network/interfaces file and then adding its ip address + hostname in c:/windows/system32/drivers/etc/hosts.

I tried uninstalling zeroconf packages and avahi packages separately and together. After deleting the avahi & zeroconf packages I notice NO difference in this vm. Connectivity is the same. How can that be ?? In my (very humble) opinion, there seems to be an abundance of unnecessary packages(read: shi...), here. Until someone has a clear answer as to e.g why this OS as standard implements redirect of ".local" & the problems I addressed above - I am scrapping Ubuntu 16.04. Thank you.


I installed libnss.myhostname package on the vm, and now I can ping it for the first name.... As "ubuntu.local". Problem is, it only returns ipv6 addresses, and the computer still doesn't show up under networks in Windows.

EDIT I added .local to the "ubuntu" name in the file hostname. Now I can ping "ubuntu.local", and I get in return ipv4 addresses. Still, the hostname(or rather the netBIOS) name does not appear under Windows network. As I've learned, because Windows can not reference the mapping of it in the dns database.

  • Could you fragment your question into paragraphs. – ankit7540 Feb 1 '17 at 5:32
  • Set the network adapter type to Bridge. – L. D. James Feb 1 '17 at 6:23
  • Setting the connection to bridged doesn't work. This could be some easy fix I know, but it is infuriating! – PushT Feb 1 '17 at 16:42

I will be so bold as to answer my own question, as I indeed solved the problem myself. I installed Samba packages on the Ubuntu vm, and added wins to the line

hosts:          files mdns4_minimal [NOTFOUND=return] dns wins mdns4

in the /etc/nsswitch.conf - file.

I do read that it is not good practice to install Samba server just for hostname/netBIOS name resolution, but unless someone can deliver a better solution for a NAT - setup with vmware workstation, I don't really care...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.