1

I've tried installing MRAA both via apt and building it from its github source. I can run mraa-gpio and mraa-i2c on the commandline, and I can turn LEDs on and off with the GPIO javascript example. But, when I try to run the SPI javascript example, I get an error at the moment of instantiation:

(classic)thosmos@localhost:~/hello-node$ sudo nodejs
> var m = require('mraa');
undefined
> x = new m.Spi(0)
Error: Illegal arguments for construction of _exports_Spi
  at Error (native)
  at repl:1:5
  at REPLServer.defaultEval (repl.js:252:27)
  at bound (domain.js:287:14)
  at REPLServer.runBound [as eval] (domain.js:300:12)
  at REPLServer.<anonymous> (repl.js:417:12)
  at emitOne (events.js:82:20)
  at REPLServer.emit (events.js:169:7)
  at REPLServer.Interface._onLine (readline.js:210:10)
  at REPLServer.Interface._line (readline.js:549:8)
> 

Is there a step I'm missing for getting this working?

7
  • What hardware is this on?
    – kyrofa
    Jan 31 '17 at 20:36
  • This is on an Intel Joule Jan 31 '17 at 23:24
  • And running Ubuntu Core 16.04 Jan 31 '17 at 23:30
  • The Joule is a bit different. I've logged a bug for this issue to be investigated and will report back once I have an answer.
    – kyrofa
    Feb 1 '17 at 18:46
  • Thanks for following up on this. Where was this bug report logged (with Ubuntu, Intel, or somewhere else)? Feb 3 '17 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.