6

I have Ubuntu 16.04 installed with Unity (Ubuntu-Desktop).

As mentioned in several other threads, I have:

  • Under Settings → Brightness & Lock set Turn screen off when inactive for to “never”.
  • Under Settings → Power set Suspend when inactive for to “don’t suspend”.
  • With dconf-editor in the directory /org/gnome/settings-daemon/plugins/power unchecked active.
  • With dconf-editor in the directory /org/gnome/desktop/screensaver unchecked idle-activation-enabled (even though that seems deprecated in 16.04).
  • Run gsettings set org.gnome.desktop.session idle-delay 0
  • Run gsettings set org.gnome.desktop.screensaver lock-enabled false

Still, Ubuntu keeps turning the screen off after 10 minutes (not locking it though). Any ideas on what to try?

Also, I have the same problem whether I decide to launch Unity or not. (When I'm in terminal only, not running LightDM, screen also goes black after 10 minutes.)

Output from xset q:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On
  • Will you edit your question and insert the results of xset q? – L. D. James Jan 31 '17 at 21:58
  • sudo apt-get install dconf-editor and check there if sleep is active. Edit: nvm you already did that – Pavlos Theodorou Feb 1 '17 at 9:19
  • have you installed another app that used or use to control the display screensaver sleep hibernation ? – Pavlos Theodorou Feb 1 '17 at 9:22
  • and also test if $xset dpms force off helps. if you want to turn it back on: $xset -dpms – Pavlos Theodorou Feb 1 '17 at 9:24
  • Isn't there actually a problem with the 'xset q' output ? Shouldn't timeout and Standby be 0 instead of 600? – ylnor Feb 1 '17 at 9:28
3

Your monitor is being turned off every 10 minutes because of the setting you have in:

timeout:  600    cycle:  600

The 600 seconds timeout is 10 minutes. You can disable this timeout by changing this setting to 0.

You can do this with:

$ xset s 0 s blank

I don't know what in your system is making this a default. But you can make this an automatic change by creating a script to change this and placing the script in your Startup Applications configuration:

Script to disable blanking:

#!/bin/bash

xset s 0 s blank

Copy the script to ~/bin/.

Now set it to automatically run by typing start applications in the Ubuntu Search button and clicking Startup Applications

Click the option to Add, then browse to the script and add it.

  • Thanks a lot, that did the trick. But as expected went back to timeout=600 after reboot. I will add your script as a workaround, but is there a way to find out what in my system is changing it? – ylnor Feb 1 '17 at 10:57
  • 1
    I'm glad it worked... I can imagine the frustration. It may have to do with the default configuration of hardware drivers on your system. You can change make this setting a default by adding the line to your .xesssionrc or .xinitrc. I have a similar problem whereas my preferred mouse speed doesn't survive reboots. I just use a similar script that I provided for you to set my preference at boot time. By the way, if you see some value in my answer, consider an upvote. – L. D. James Feb 1 '17 at 11:13
  • @L.D.James Many thanks, although I was coming at it from the opposite direction, I needed to get my monitors to shut down after some hours idle, and your answer pointed me at the right tool to get it done. – EdwinW Aug 27 '17 at 18:22
0

I may be off base here, but check the settings on your monitor. Some of the newer monitors have an "Energy Saving" feature which work independent of the OS and may turn off after a set amount of time of inactivity.

  • Thanks, but that's not the case here... – ylnor Jan 31 '17 at 18:37
0

10 minutes is the default X-server screen saver timeout so it is likely the culprit. Edit or create a new /etc/X11/xorg.conf. Add the following section:

Section "ServerFlags"
    Option "BlankTime" "0"
EndSection
  • 2
    what does that suggestion say? – Pierre.Vriens Jun 3 '17 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.