5

My built-in microphone is not working properly on programs like google chrome (hangouts), skype. But when I execute pactl load-module module-loopback I get the feedback perfectly.

Google chrome (hangouts) does not receive any audio. Skype receives but outputs a very low and buzzing sound.

I changed /etc/modprobe.d/alsa-base.conf to add options snd-hda-intel model=auto and options snd-hda-intel model=ideapad but did not work(Internal microphone not working).

I am using xubuntu 16.04.

My ALSA Info:

http://www.alsa-project.org/db/?f=d26bc657f286b380d5facf45b0573f68117524ad

Any suggestion ?

  • It's only with those programs or those are the only ones you tested? – user589808 Jan 31 '17 at 14:13
  • @CelticWarrior They were the only I tested. – Iago Jan 31 '17 at 15:55
8

My Lenovo G70-80 built-in microphone was not working. I followed this ubuntu wiki help page.

Under Increasing very low microphone input, point 5, Switch one of the input channels off solved my problem. This notebook has only one mono microphone so one channel should be switched off. It's not important which - left or right.

  1. Go to Input Devices tab and ensure you have the Internal Audio Analog Stereo or just Internal Audio Analog displayed by selecting All input devices from the Display drop-down list.

  2. Find the appropriate input device (microphone) and ensure its not muted - by unticking mute audio icon.

  3. Unlock channels so that they are not linked together - by pressing a padlock icon or chainlink icon. Slide the slider of Front Right all the way down to zero.

  4. Talk to the microphone observing input level on the bar just below the two sliders or at the Input tab of Gnome-volume-control.

  5. This should work when either channel is muted, though it is suggested to start with Front Right one.

  • After short time it is not working again. I set volume for microphone in pavucontrol for instance to 75%, but when I started talking in Skype it is set to very low value about 10%. – Lubomir Bielik May 11 '17 at 12:40
  • This really worked! In order to make use of the answer, people should really follow the link. Otherwise it's hard to understand the box, because the instructions are all about pavucontrol. – MERose Jul 11 '17 at 19:17
  • I install new version of Skype 5.4.0.1, but no improvement. When I test microphone with Pulse Audio Volume Control it works - volume control does not change it's value. I guess, that Skype controls microphone wrong. And I cannot find in Skype some option to inhibit it. – Lubomir Bielik Sep 17 '17 at 16:24
  • 1
    Finally this did the Job. May the gods be with you... – messerbill Sep 2 '18 at 23:10
3

For everyone who has similar problem. On my Lenovo ideapad 310 and Skype i had to:

1 Open pavucontrol (install it if missing with sudo apt-get install pavucontrol)

2 Call to someone or to Echo / Sound Test service (more important step :) )

3 Go to "Recording" tab, you will see smth. like "Chrome input"

4 When on "Recording" tab - Unlock channels so that they are not linked together - by pressing a padlock icon or chainlink icon. Slide the slider of Front Right all the way down to zero.

Thanks to this - even after restart mic was working properly.

  • I had already tried to select the correct input device with the sound control in KDE's control panel (AFAIK from KMix) but it did not work. With pavucontrol I could actually see the input level and select the correct input device with the correct input stream. – Daniel Böhmer Jan 16 at 9:29
1

Yup! I had the same problem in ubuntu 16.10, like working perfectly on skype but doesn't work for chrome. So I solved the problem just by reducing the Front Right slider under input Devices on PulseAudio Volum Control. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.