1

My 75 years old mother has big problems in clicking on Unity launcher icons to start applications because she always moves the mouse a bit which prevents the left-click to be accepted. As a work-around I suggested to use Super+Number instead, but I also want her to use her mouse.

Is there a setting to prevent launcher icon rearrangement? This would solve the problem because a left mouse click would start the application even if the mouse would be moved a little bit at the same time when clicking.

  • Hi Ralf, just curious, but did you try? – Jacob Vlijm Feb 1 '17 at 14:27
3

Sounds familiar.

Simulated left-click

An elegant solution would be, I think, to make her use the mouse, but replace the "real" mouse click by the key combination Alt+Z. I would also add a small delay of 1 second, to make the action "relaxed".

How to set up

Setup is simple:

  1. Install xdotool

    sudo apt-get install xdotool
    
  2. Add the shortut key: Choose: System Settings > "Keyboard" > "Shortcuts" > "Custom Shortcuts". Click the "+" and add the command:

    /bin/bash -c "sleep 1 && xdotool click 1"
    

    to the key shortcut Alt+Z.

Now she can simply move the mouse to whatever she wants to click, then press Alt+Z to click.

(I posted this answer with the simulated click :) )

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.