8

My wifi has actually worked well until recently. I had put the files from kvalo/ath10k-firmware.git in /lib/firmware as per No Wifi in Qualcom Atheros - Ubuntu 16.04 - Acer Aspire E 15 and Problems with Qualcomm Atheros QCA6174 in Ubuntu 16.04 and others.

However, I still have major problems. Even plugging in a wifi dongle has issues, but one problem at a time - problem is definitely this device. The rest of the devices on my network are totally fine.

Running Ubuntu 16.10 on Acer Aspire V15 Nitro laptop.

jonathan@melange:~$ lspci -nnk | grep -iA2 net; dmesg | grep ath10k
07:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Foxconn International, Inc. QCA6174 802.11ac Wireless Network Adapter [105b:e09d]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1025:1039]
    Kernel driver in use: r8169
    Kernel modules: r8169
[    5.777028] ath10k_pci 0000:07:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    6.058560] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:07:00.0.bin failed with error -2
[    6.058568] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[    6.061957] ath10k_pci 0000:07:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 105b:e09d
[    6.061959] ath10k_pci 0000:07:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    6.062416] ath10k_pci 0000:07:00.0: firmware ver WLAN.RM.4.4-00022-QCARMSWPZ-2 api 5 features wowlan,ignore-otp crc32 4d458559
[    6.128304] ath10k_pci 0000:07:00.0: failed to fetch board data for bus=pci,bmi-chip-id=0,bmi-board-id=0 from ath10k/QCA6174/hw3.0/board-2.bin
[    6.129084] ath10k_pci 0000:07:00.0: board_file api 1 bmi_id 0:0 crc32 ed5f849a
[    8.181802] ath10k_pci 0000:07:00.0: Unknown eventid: 90118
[    8.181838] ath10k_pci 0000:07:00.0: htt-ver 3.32 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    9.207221] ath10k_pci 0000:07:00.0: suspend timed out - target pause event never came
[    9.292828] ath10k_pci 0000:07:00.0 wlp7s0: renamed from wlan0
[   11.516595] ath10k_pci 0000:07:00.0: Unknown eventid: 90118
[   14.579410] ath10k_pci 0000:07:00.0: failed to set rx-chainmask: -11, req 0x3
[   17.651411] ath10k_pci 0000:07:00.0: failed to set arp ac override parameter: -11
[   23.795416] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[   26.083746] ath10k_pci 0000:07:00.0: Unknown eventid: 90118
[   29.171309] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[   35.315207] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[   37.602389] ath10k_pci 0000:07:00.0: Unknown eventid: 90118
[   40.691216] ath10k_pci 0000:07:00.0: failed to set tx-chainmask: -11, req 0x3
[   43.763273] ath10k_pci 0000:07:00.0: failed to set arp ac override parameter: -11
  • I encounter this in Dell Inspiron 15, 5000series. using ubuntu 18.04 – ji-ruh Jul 8 '18 at 12:36
8

I think you may be suffering from a couple different issues. I want you to reinstall the Ubuntu package linux-firmware as that may be more up to date than kvallo's github site

sudo apt-get install --reinstall linux-firmware

A recent change to network manager enables wifi powersave by default, to disable this do

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot

  • Is skip_otp=y helpful? – chili555 Jan 31 '17 at 0:58
  • 2
    Ok I found that simply deleting the ath10k folder in /lib/firmware then doing the reinstall of linux-firmware helped, as there must of been some of my mods that were causing issues. I'm not sure the powersave is an issue though, as I can't tell if it makes a difference. I think we're working again now. Thanks – jbbiomed Jan 31 '17 at 1:43
  • @chili555 that might be taken care of in firmware now features wowlan,ignore-otp – Jeremy31 Jan 31 '17 at 10:02
  • @Jeremy31 Ahh! Thanks for the heads-up! – chili555 Jan 31 '17 at 13:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.