I installed the fingerprint reader successfully on Ubuntu 16.04 and ran fprintd-enroll with apparent success. When I rebooted, the fingerprint was requested but failed 3 times and then asked for my password. I thought I'd try enroll again, but it failed before it finished and I had to control c out. Logged out and in and tried again, but now I consistently get a failure "device already claimed." How can I clear that claim so I can try again? And/or, how do I uninstall it? Sorry, I'm a noob with Linux.

I installed on my T410 using: sudo apt install libpam-fprintd as shown on page: How to install a fingerprint reader on Lenovo ThinkPad

  • How did you install the software? Please edit and describe what you installed and how. If you followed some tutorial please link it.
    – user589808
    Jan 30, 2017 at 22:05

2 Answers 2


I encountered the same error. Simple solution: Stop the fingerprint daemon.

sudo service fprintd stop

Previously I enrolled fingerprints using the terminal. Later I tried to handle everything in the Settings GUI, where the error occured.


From a terminal (start one with Ctrl-Alt-t) type

sudo apt-get purge fprintd

Then try a reinstall and re-scan several fingers.

You do realize anything relying on the keyring will still require a password? I dropped fingerprint scanning because I still needed a password, and the scanning was just an extra step.

The error is probably from another process running update or in some way accessing that package directory, maybe in the background. Stop anything like Software Updater or synaptic and try again. If it's just the lock file, and not the directory, you may just delete it and try again (use sudo on the rm command).

  • Thanks. Sounds like good advice. Too bad the keyring doesn't use the finger print too. Jan 30, 2017 at 22:38
  • The purge resulted in this error--how do I get past this?E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? Jan 31, 2017 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.