So after getting my new lenovo H330 with Intel graphics I've been trying to get some native client applications working. I typically used the only browser to have NaCl built in by standard which is of course Google chrome. According to the web, Intel mesa drivers that my computer came with (there's no PCI or PCIE graphics card) earlier then 7.9 won't work but according to 'chrome://gui' my version is 7.11. but never the less I could only get some of these NaCl compiled applications working about 7% of the time. We eventually found it was a problem with the Intel mesa graphics not supporting WebGL. You may have seen my previous question here on askubuntu.

Now for the new twist in this saga. For no reason at all I decided to open Firefox and test some WebGL examples with it. I navigated to http://www.ibiblio.org/e-notes/webgl/webgl.htm and take a guess what happened? Firefox DID work with all the examples I tried and furthermore worked 100% of the time. I went to the same site back with Chrome to find that it DIDN'T work with any of the examples 100% of the time. As far as I can find there isn't any NaCl plugin for Firefox so I can't test the actual applications that failed with Chrome. I tried everything to get Chrome to work like disabling the blacklisted GPU filter in about:flags, making sure WebGL was enabled and using the latest Chrome version. But to no avail.

So now. Why does Firefox play nicely with WebGL when Chrome just wants to sit in the corner?

1 Answer 1


I find out that Chromium works with some things that Chrome doesnt, if this help you, WebGL works here.

  • I forgot all about chromium. I've installed version 15 from the ubuntu software centre but it's still suffering the same fate as regular chrome. According to it's wiki page the latest version of chromium is 18 but I don't know where I can get such version for Ubuntu.
    – RADXack
    Dec 14, 2011 at 19:33
  • 1
    launchpad.net/~chromium-daily/+archive/ppa also look at the about:flags configs Dec 14, 2011 at 19:39
  • Ah thanks. I've installed version 17 now but after enabling webgl, Nacl and disabling the blacklist I'm still unable to view the webgl examples. So far it's still only Firefox that works with them.
    – RADXack
    Dec 14, 2011 at 19:46
  • 1
    Beware the button on about:flags say to Enable the Disable of WebGL (its confusing), also enable the border remark or hardware accelerated content, so you can check it out, maybe graphic hardware its the problem. Dec 14, 2011 at 19:49
  • Oh my god that's the problem. I had the 'WebGL: disable webgl' option enabled. So it was really disabled. All this time it was that. That really is worded rather weirdly. I've just tried normal chrome and everything's working great. Thanks alot! (Woas me)
    – RADXack
    Dec 14, 2011 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .