3

When I am trying to switch to another wifi network. I am getting below error

(1) Private connection already active on the device: uid 1002 has no permission to perform this operation

Refer attached image.

enter image description here

My machine details:-

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial

What is the actual problem here and how to solve this ?

4
  • Let know who or what has the uid 1002 with cat /etc/passwd | grep 1002 Jan 30 '17 at 6:00
  • cat /etc/passwd | grep 1002 karunakaranpalm:x:1002:1002:KarunakaranPALM,,,:/home/karunakaranpalm:/bin/bash
    – Galet
    Jan 30 '17 at 6:24
  • I am guessing that's you, so you need to first disconnect the wifi from any previous operations before using it else where. Jan 30 '17 at 6:26
  • @George When I click disconnect option in Wifi. I see same error as "Connection activation failed" in attached screen-shot
    – Galet
    Jan 31 '17 at 5:00
1

Last time I got this, I was logged in as user A, but another user B on the same machine was logged in at the same time. I logged out from both of them, logged in as A again and then everything worked fine.


Alternatively, https://github.com/blueman-project/blueman/issues/773 suggests users should be a member of at least one of the sudo or the netdev groups. To add your current user to netdev, simply:

sudo gpasswd -a $USER netdev

(See the file /usr/share/polkit-1/rules.d/60-network-manager.rules for the actual test-for-group-membership.)

0

Above issue is specific to user. I am able to switch wifi networks in other users. I have enabled "All users may connect to this network" option in Networks conneciton and restarted my machine. Now I didn't see the above issue when I switch Wifi network.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.