0

Ubuntu 16.04.1 xenial on bare metal Intel NUC.

I've been using a wired connection for sometime now and wish to now switch to wireless (relocating box).

I've connected to the wireless router. A notification comes up saying I'm connected to it. The connection information says my active network connection is to that wireless router with an IP of 10.1.1.205, and a default route and DNS of 10.1.1.1.

The wired connection was 10.1.1.3.

But when I ping the gateway at 10.1.1.1 it says:

From 10.1.1.3 Destination Host Unreachable

I've tried the below that I've read elsewhere (eg. https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1576215) is meant to fix this problem:

sudo service network-manager restart

But this doesn't fix the problem and I cannot use the wireless network.

Any ideas?


Updated with more information

  • Based on initial comments

    $ cat /etc/resolv.conf

    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 8.8.8.8 nameserver 4.4.4.4 nameserver 127.0.1.1

    $ cat /etc/network/interfaces

    # interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback

    source /etc/network/interfaces.d/*.cfg

    $ ls -la /etc/network/interfaces.d/

    total 4 -rw-r--r-- 1 root root 165 Dec 30 10:48 eth0.cfg

    $ cat /etc/network/interfaces.d/eth0.cfg

    auto eth0 iface eth0 inet static # address 192.168.1.4 address 10.1.1.3 netmask 255.255.255.0 # gateway 192.168.1.1 gateway 10.1.1.1 dns-nameservers 8.8.8.8 4.4.4.4

I haven't tried the modprobe suggestion in a comment as it sounds permanent. I will do a bit of reading first.

Further investigations

Doesn't this seem odd:

$ iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"starkiller24"  
      Mode:Managed  Frequency:2.417 GHz  Access Point: xx:xx:xx:xx:xx:xx   
      Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=70/70  Signal level=-29 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:42   Missed beacon:0

eth0      no wireless extensions.

$ sudo ifup wlan0
Unknown interface wlan0

Would creating an interface in /etc/network/interfaces.d help? And if so why hasn't one been created?

  • 2
    Is the wired connection unplugged ? – George Udosen Jan 29 '17 at 12:23
  • Please edit the question to include results for cat /etc/resolv.conf and cat /etc/network/interfaces – Jeremy31 Jan 29 '17 at 13:19
  • George was right. You need to simply unplug the Ethernet cable or remove the driver from the Kernel (modprobe -r driver_name) and then the WiFi should automatically take over. – WinEunuuchs2Unix Jan 29 '17 at 16:54
  • Thanks for the feedback. I'll update the question and try the suggestion tongiht (12 hours). – HankCa Jan 29 '17 at 21:35
  • Oh, and i had unplugged the ethernet. – HankCa Jan 30 '17 at 2:47
0

As noted in my answer I had the interface for eth0 defined in /etc/network/interfaces.d/eth0.cfg. I simply had to remove that and wireless now works! So must be some kind of automatic configuration must be happening.

I played around with defining a wlan0.cfg but that was unnsuccessful. I'm sure I just had a settings mismatch and I will attempt this task again at another time (for educational purposes).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.