10

It's been the last two days that out of nowhere - my chromium/chrome browser is constantly crashing with the aw snap error / where firefox works without issue. I thought this might be related to an issue I was having with my last pass extension(as I was experiencing a known bug with their extension at this time). Since then I rebooted/disabled all my extensions and tested again - still the same issue happening constantly! Checked forums, confirmed in dmesg that I was running out of memory (I'm on a 16gb Dell XPS 13 with hardly any tabs open):

[20968.163307] Out of memory: Kill process 11700 (chromium-browse) score 304 or sacrifice child [20968.163312] Killed process 11700 (chromium-browse) total-vm:2017292kB, anon-rss:123152kB, file-rss:84092kB

Adding apt-cache policy:

chromium-browser:  
  Installed: 55.0.2883.87-0ubuntu0.16.04.1263  
  Candidate: 55.0.2883.87-0ubuntu0.16.04.1263  
  Version table:  
 *** 55.0.2883.87-0ubuntu0.16.04.1263 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     49.0.2623.108-0ubuntu1.1233 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

I then amended my swappiness from 60 to 10 following these instructions: How do I configure swappiness? Still had the same issue... Read another link about extending my minvmfreekbytes - where I increased it to 160mb : https://blog.kylemanna.com/linux/google-chrome-aw-snap/ ..still the same issue.. Can someone please help? It seemed to work fine for the last month and I have all my extensions set up so I want to avoid changing browser. Thanks

closed as off-topic by Zanna, David Foerster, Fabby, Eric Carvalho, Elder Geek Feb 9 '17 at 16:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Zanna, Fabby, Eric Carvalho, Elder Geek
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you add more information about the exact Chromium version and origin you use? It would be nice if you would edit your question and post the output of the command apt-cache policy chromium-browser therefore. Thanks. – Byte Commander Jan 30 '17 at 0:22
  • 1
    What kernel version do you use (see the output of uname -r)? This may be bug #1655842. – David Foerster Feb 4 '17 at 8:02
  • i wish the hall monitors wouldn't close useful stuff. – user1130176 Feb 14 '17 at 19:25
8

This appears to be a kernel issue, discussion here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1655842

It is claimed that this will be fixed by the next kernel update.

A quick and dirty fix that appears to work is this:

sudo su
echo 3 > /proc/sys/vm/drop_caches

edit: Seems like the "fix" needs to be applied every ~12 hours. A more permanent solution is to downgrade the kernel to 4.4.0-57.

Not the answer you're looking for? Browse other questions tagged or ask your own question.