0

Comcast installed a gigabit modem today, and gave me the Netgear R8000 router. The tech installed the modem, showed me the device he was using to provision the modem when he was done, and it showed 951 down and 40 up.

Im seeing a max of 300-400Mbps speeds on wired devices and I want to make sure everything is solid on my side before complaining.

I have a Ubuntu 16.04 server with a gigabit port wired to a gigabit switch, which is wired to the R8000. I updated the MTU to 9000 and get the following with ip link

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
mode DEFAULT group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc mq state 
UP mode DEFAULT group default qlen 1000
link/ether 40:6c:8f:23:15:8c brd ff:ff:ff:ff:ff:ff
3: wlp3s0b1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode 
DEFAULT group default qlen 1000
link/ether 70:73:cb:c3:f2:fb brd ff:ff:ff:ff:ff:ff

speedtest-cli gives me

speedtest-cli
Retrieving speedtest.net configuration...
Testing from XFINITY (98.192.74.246)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Tulix Systems, Inc (Atlanta, GA) [37.65 km]: 17.766 ms
Testing download
speed.................................................................
Download: 422.33 Mbit/s
Testing upload 
speed..................................................................
Upload: 40.24 Mbit/s

Shouldn't I be seeing at least twice that down speed on a gigabit line? Can you think of any other settings I need to check to make sure its not my config? What other detail can I provide?

The wireless devices are all fine and maxing out around 300 down.

Thanks.

  • Plug the machine straight into the modem and see if it gets better. – TheWanderer Jan 28 '17 at 23:48
  • Why did you select MTU 9000? Was that figure given to you by Comcast or ... what? – chili555 Jan 29 '17 at 0:57
  • I did try plugging directly into the modem but it doesn't give out an IP address. I added the MTU after doing some searching. I don't care what the value is, but do want whatever the best setting needs to be. – spalmisano Jan 29 '17 at 1:06
  • Do you get gigabit when you use multiple streams? – user508889 Jan 29 '17 at 1:19
  • I don't know what that means. What do you mean by multiple streams? – spalmisano Jan 29 '17 at 1:22
1

The maximum available MTU setting is determined by the Comcast modem. You should check in the administration pages of the modem to see the MTU that is used.

If you are unable to do so, you can determine the maximum MTU that can be utilized with ping. For example, on my machine:

ping -s 1472 -c3 google.com
PING google.com (74.125.138.113) 1472(1500) bytes of data.
72 bytes from yi-in-f113.1e100.net (74.125.138.113): icmp_seq=1 ttl=43 (truncated)
72 bytes from yi-in-f113.1e100.net (74.125.138.113): icmp_seq=2 ttl=43 (truncated)
72 bytes from yi-in-f113.1e100.net (74.125.138.113): icmp_seq=3 ttl=43 (truncated)

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 10.703/11.242/11.907/0.506 ms

If I increase the size to, for example, 1600, then I get:

ping -s 1600 -c3 google.com
PING google.com (74.125.138.101) 1600(1628) bytes of data.

--- google.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2038ms

As you can see, I then get 100% packet loss.

You should always add 28 to the packet size in order to get the real MTU because 20 bytes are reserved for the IP header and 8 bytes must be allocated for the ICMP Echo Request header.

In my case, the result is 1500 which is, remarkably, the default setting in both my AT&T gigabit modem and my router.

Please reset your MTU to 1500 and tell us if connectivity is improved.

  • It was 1500, assigned by DHCP originally, which I edited after searching in hopes of figuring this out (saw several threads showing 9000 when using a gigabit connection). Returning to 1500, again assigned by DHCP, has no impact to speeds. Still getting Download: 449.16 Mbit/s – spalmisano Jan 29 '17 at 16:15
  • Let's take a look at any interesting messages in the log: 'cat /var/log/syslog | grep enp` As the output may be lengthy, paste the result here and give us the link: paste.ubuntu.com – chili555 Jan 29 '17 at 17:20
  • Here you are: paste.ubuntu.com/23889967. This reads like its as it should be; anything jump out? – spalmisano Jan 29 '17 at 22:01
  • I see this: "vnstatd[708]: Info: Traffic rate for "enp2s0f0" higher than set maximum 1000 Mbit" Frankly, I'm unfamiliar with vnstatd. This link suggests that there is a file that may need to be edited to set the correct rate.ubuntuforums.org/showthread.php?t=2263057 Next, this looks great! " enp2s0f0: Link is up at 1000 Mbps, full duplex" Finally, I notice that the name of the computer is evidently 'media'. If you are running off of a live session DVD or USB, I'd expect everything to run a bit slower. – chili555 Jan 29 '17 at 23:14
  • The hostname of the computer is media; its not run off of removable media of any kind. Im also not familiar with vnstat and it must be something that was installed as part of the default profile for Ubuntu 16.04 server. – spalmisano Jan 30 '17 at 0:03
0

Ubuntu definitely isn't the problem. I connected a macOS device directly to the modem and the speeds are the same. Comcast is going to replace the modem tomorrow. This afternoon they tried to tell me because I wasn't using Windows 10 the issues were my hardware. Thanks for all of the troubleshooting.

For posterity: as long as you have a standard Ubuntu environment and don't muck with the MTU or other default parameters of networking, don't let them tell you you're the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.