0

This nomachine forum topic didn't help.

After reboot I have these envs:

GDM_LANG=en_GB  
LANG=en_GB.UTF-8  
LANGUAGE=en_GB  

cat /etc/default/locale

#  File generated by update-locale
LANG="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"

but my timezone is for my country and differs from english language option.

Could nomachine be using the timezone to set it's language? This is quite complicated because the translation to my native lang is not good; the terminology used is so strange. So I prefer to stick with English than getting confused every time I open nomachine.

but how to fix/modify the language?

My entire Ubuntu installation is in English, all apps open in English, least nomachine (as far I know)

1

You appear to have English in your locale settings. You don't mention what language it is you are seeing instead of English.

To change the language in the client application is easy:

  1. Open the GUI on the machine you are connecting from.
  2. Click settings.
  3. Click Appearance.
  4. Choose your language.

There is a useful tutorial on the NoMachine website which may help you: https://www.nomachine.com/customizing-appearance-nomachine-gui

  • oh... *blush*, it is not the 1st time the obvious defeat me :), thx vm! – Aquarius Power Feb 1 '17 at 1:03
  • It would still be interesting to know what the language is was set in the NoMachine GUI. I have Italian as my language setting and don't have any problems. The language gets set when you install according to what's on your locale or what you manually set. – Stickerroot Feb 1 '17 at 8:05
  • I dont remember having set that option manually. It should be translated to pt-BR, but there is only pt-PT, and it got set to the latest one that is quite confusing ex.: "connecting to ..." will be "ligando para ..." (pt-PT, but here it sounds like making a call, like using a modem to make a call) instead of "conectando-se a ..." (pt-BR). – Aquarius Power Feb 1 '17 at 21:19
  • anyway, any problems we have, the answers can usually be found in english, there isnt so much answers in my nat lang, so I use everything (all applications) in english to lose less time to fix problems. – Aquarius Power Feb 1 '17 at 21:20
  • I understand that PT and BR are quite different, though I'm not an expert. Is it like British English vs American English or much more complex? – Stickerroot Feb 2 '17 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.