2

I have a fresh install of Ubuntu 16.10, with two users set up. If I lock the screen when I am logged in (either manually or through inactivity), there is no way for the other user to log in. The buttons in the top menu do nothing, and only my name shows on the screen.

  • Do you, or do you not see "Switch User" on the lock screen? Smells like this. – earthmeLon Jan 28 '17 at 20:00
  • It does smell a lot like that, I agree. I do not see a switch user option. – Feasoron Jan 28 '17 at 20:05
  • On the lockscreen, if I click the gear, I have Switch Account, Guest Account, or Suspend. Also running 16.10 here. – SuperSluether Jan 29 '17 at 1:59
  • If I click the gear, it highlights but nothing opens. – Feasoron Jan 29 '17 at 14:00
  • try this '$sudo apt-get --purge gnome-screensaver ;sudo apt-get --reinstall install -f gnome-screensaver' – Pavlos Theodorou Feb 1 '17 at 0:56
2
+50

Seems you have Gnome's user-switching option disabled.

You can check this running gsettings get org.gnome.desktop.lockdown disable-user-switching, which should return true if its disabled.

Maybe it has been disabled from Unity Tweak Tool, dconf-editor, or other tweaking tool. Anyway you can restore that functionality in a couple of ways (or more).

Changing user-switching from terminal (gsettings)

  • You can enable the user-switching option again running:

    gsettings set org.gnome.desktop.lockdown disable-user-switching true

  • To disable it again simply run:

    gsettings set org.gnome.desktop.lockdown disable-user-switching false

Changing user-switching from GUI (dconf-editor)

If you prefer GUI tools for this kind of tasks, you can use dconf-editor. If you don't have it yet on your system, you can install it running sudo apt install dconf-editor.

  • Open dconf-editor from Unity's dash.
  • Navigate to org.gnome.desktop.lockdown on the left pane.
  • Click the disable-user-switching item on the right pane.
  • Change its value (true/false) from popup window and hit save button.

Personally, I prefer to keep it disabled (for security reasons) on systems without such requirements (Examples: one user only, no need for fast user switch, etc...).

Hope it helps.

  • 2
    you should first propose gsettings get org.gnome.desktop.lockdown disable-user-switching to see if its true or false – Pavlos Theodorou Feb 1 '17 at 1:08
  • @PavlosTheodorou you're right, thanks for that point! answer updated. – dgonzalez Feb 1 '17 at 1:11
  • That did it! Thanks. I'll award the bounty as soon as the time expires. I'm not sure how this happened - I've been running nothing Ubuntu on multiple systems in my house since 2009 and never hit this. Worth the bounty to learn something new and keep peace in the family. – Feasoron Feb 1 '17 at 1:15
  • @Feasoron Glad to read it helped you out! – dgonzalez Feb 1 '17 at 1:17
0

I'm not allowed to comment so I have to copy and correct the answer...

Seems you have Gnome's user-switching option disabled.

You can check this running gsettings get org.gnome.desktop.lockdown disable-user-switching, which will return true if its disabled.

Maybe it has been disabled from Unity Tweak Tool, dconf-editor, or other tweaking tool. Anyway you can restore that functionality in a couple of ways (or more). Changing user-switching from terminal (gsettings)

You can **disable** the user-switching option by running:

gsettings set org.gnome.desktop.lockdown disable-user-switching true

To **enable** it again simply run:

gsettings set org.gnome.desktop.lockdown disable-user-switching false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.