0

I'm on 16.10 and I can't force the use of my integrated Intel GPU. System always uses my NVIDIA GPU. I've installed the latest NVIDIA driver (378) and I can't see PRIME profiles in the NVIDIA X Server Settings. Additionally, when I try to use prime-select to select the Intel profile I get the following message

the current EGL alternative in use are ['nvidia-378', 'nvidia-378']
selecting nvidia-378-prime for the intel profile

All the solutions online involve just installing the newest drivers which I already have.

In my "additional drivers" settings I have the NVIDIA 378 selected and the "Using Processor microcode firmware for Intel CPUS from intel-microcode" selected.

Any help would be greatly appreciated.

EDIT:

For posterity the issue was fixed by going into my BIOS and setting my iGPU to be the primary display adapter. After that, I had issues with starting X. I was able to fix this by removing nomodeset from my default grub start command and replacing it with i915.modeset=1. After that I updated my grub and initramfs with sudo update-grub and sudo update-initramfs -u. Then when I rebooted it worked.

EDIT 2:

Removed i915.modeset=1 from grub start command. Turns out just removing nomodeset was all I needed to do. Additionally, prime profiles is now available in my NVIDIA X Server Settings.

  • Is it a laptop? What is the GPU? – Pilot6 Jan 28 '17 at 19:17
  • Not a laptop. GPU is a 970. – Valevalorin Jan 28 '17 at 19:19
  • Why do you need the i915.modeset=1? It is default anyway. – Pilot6 Jan 28 '17 at 20:19
  • You were right. It wasn't needed. – Valevalorin Jan 28 '17 at 20:23
  • Prime profiles are available, but useless in your case, I am afraid. You can remove nvidia-prime from a desktop. – Pilot6 Jan 28 '17 at 20:27
0

If you have a desktop system, you can't switch to your integrated GPU using any software.

prime-select works only with mobile GPUs with Optimus technology.

The only way you can do it is to plug the monitor cable into the another HDMI, or whatever, linked to your motherboard.

You can also switch the primary GPU in your BIOS settings.

  • I've been testing with with one monitor plugged into my GPU and one monitor plugged into my MOBO. At least once I tried having nothing plugged into the GPU and I got no signal on either monitor, but switching a cable over the GPU gave me a signal. The system was still trying to use the GPU even when nothing was plugged into it. – Valevalorin Jan 28 '17 at 19:28
  • How do you know that the system is trying to use the Nvidia when there is no monitor there? – Pilot6 Jan 28 '17 at 19:30
  • Shutdown. Move both cables to MOBO. Start machine. Black screens. Without turning off the machine I move a cable to GPU. Voila, picture. – Valevalorin Jan 28 '17 at 19:32
  • You can probably switch the primary GPU in BIOS. – Pilot6 Jan 28 '17 at 19:34
  • Hadn't thought of this. I'll try this and report back. Thanks. – Valevalorin Jan 28 '17 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.