I am trying to format sd card in which I first installed noobs(raspberry pi). It created its own partition tables and now I want to use the sd card for some other purpose.

I have tried the following:

1) Tried the direct format command, but it said input/output error

2) Tried sdcardformatter on windows

3) Tried gparted.

4) Used the fdisk command

After all these trials without any success, now I am trying to use the dd command. The screen shot is as follows: Screenshot of my terminal

Its been 3 hours since I have started the command. Even the amount of data processed is around 40.2M since 2 hours.

I am using 8GB machine with Intel i7 processor, ubuntu 16.04. The sd card is class 10 32GB micro SD card. It doesn't have any lock!

Any help would be appreciated. Thanks

  • dd is a most unwise and dangerous tool to use for formatting or partitioning. See better answers below.
    – user535733
    Jan 28 '17 at 22:19

I suggest that you use mkusb for this purpose. It wraps security around dd, and helps you get things right. There are menu options to wipe the first megabyte (which is often enough), or the whole device (which is slow, but might improve the write speed), or restore the drive to a standard storage device (automatically).

If mkusb fails (and you have checked that the 'lock microswitch' is not 'on', and no other process is locking the device) the drive is probably 'gridlocked', which is the first stage in the failing process. The next stage is that the drive is completely dead.

To be sure, it is a good idea to reboot the computer to get things clean and nice (and kill processes that might disturb what you want to do). You should also disconnect all other USB devices and memory cards (if possible). Then try again.

See the following links,



Pendrive lifetime

  • Hello sudodus, I have tried using this tool to format my sd card. Even after a long time the progress bar doesn't show any progress!
    – Anivarth
    Jan 29 '17 at 13:01
  • Please try 1) after rebooting. 2) in another card reader, 3) in another computer. - If still no luck, I think your SD card is damaged beyond repair (at least with tools for us regular users). Running Raspberry Pi will wear the card with many write operations on certain memory cells, and if the file system is almost full, I think the wear will be concentrated to a small number of cells.
    – sudodus
    Jan 29 '17 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.