3

Trying to follow this answer under Disabling Intel Turbo Boost in ubuntu:

In order to see the driver:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver
intel_pstate
intel_pstate
intel_pstate
intel_pstate

Then, to inquire as to the turbo enabled or disabled status:

cat /sys/devices/system/cpu/intel_pstate/no_turbo
1

That means it's on.

To disable it, I get "Operation not permitted":

echo "0" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
[sudo] password for cipeos: 
0
tee: /sys/devices/system/cpu/intel_pstate/no_turbo: Operation not permitted

Trying a suggestion in a comment under the answer (sudo echo "0" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo) I get the same thing. Even sudo su before that gives the same.

Trying to find manually the file:

sudo gedit /sys/devices/system/cpu/intel_pstate/no_turbo

It has just one line:

1

When I try to change it to 0 and save it it says: "Could not save the file “/sys/devices/system/cpu/intel_pstate/no_turbo”." and "You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again."

enter image description here

  • 2
    "1" means that turbo is disabled. It is highly likely that turbo is disabled in your BIOS, and therefore it is not possible to enable it at this level. In a few hours I can re-boot my test computer with these conditions, to verify, and then I'll write an answer. – Doug Smythies Jan 27 '17 at 17:38
  • @DougSmythies No, turbo is enabled in my BIOS settings and the operation is not permitted using sudo tee and sudo sh -c. – mchid Sep 17 '17 at 18:54
  • @mchid : Well, I can only assume that in your case something else has disabled turbo. I don't know what. I know thermald will disable turbo, but I don't know (or think) it would make it non writable by root. – Doug Smythies Sep 17 '17 at 19:46
  • 1
    @DougSmythies Probably because it is i3. I didn't think i3 had turbo but I noticed there was a setting for it in BIOS so I tried turning it on. I guess the BIOS has a generic setting for turbo even if it isn't available. – mchid Sep 17 '17 at 22:19
8

The turbo enabled or disabled flag can be misleading. Excerpt from Documentation/cpu-freq/intel-pstate.txtin the source tree:

Sysfs will show :
        max_perf_pct:100, which corresponds to 1 core ratio
        min_perf_pct:24, max_efficiency_ratio / max 1 Core ratio
        no_turbo:0, turbo is not disabled
        num_pstates:26 = (max 1 Core ratio - Max Efficiency Ratio + 1)
        turbo_pct:39 = (max 1 core ratio - max non turbo ratio) / num_pstates

So, in this case the "1" means turbo is disabled. For most computers, turbo can be disabled in the BIOS, in which case one can not override the indicator flag in Sysfs. Example 1 (turbo is disabled in the BIOS):

$ echo 0 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
0
tee: /sys/devices/system/cpu/intel_pstate/no_turbo: Operation not permitted

Example 2 (turbo is enabled in the BIOS):

$ cat /sys/devices/system/cpu/intel_pstate/no_turbo
1
$ echo 0 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
0
$ cat /sys/devices/system/cpu/intel_pstate/no_turbo
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy