2

I know I'm not the first to face this issue. I've been searching the web for days and tried every suggested solution but nothing worked for me.

My system:

I'm running Ubuntu 16.04,

lspci | grep -i vga

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] (rev ff)

The problem:

I try to start my machine. grub shows up and I can choose Ubuntu. The Ubuntu-loading screen appears. Next, the "The system is running in low-graphics mode" window appears. I can click on "ok" (using keys, mouse is not shown) and also select one of the options in the next window, but none of them takes me anywhere but back to the same window. I can use [ctl]+[alt]+[F1] to open a tty.

Let me post some log files:

/var/log/lightdm/lightdm.log:

[+0.09s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.09s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=1205
[+0.09s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.09s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.09s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.09s] DEBUG: Registered seat module xlocal
[+0.09s] DEBUG: Registered seat module xremote
[+0.09s] DEBUG: Registered seat module unity
[+0.09s] DEBUG: Monitoring logind for seats
[+0.09s] DEBUG: New seat added from logind: seat0
[+0.09s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.09s] DEBUG: Seat seat0: Starting
[+0.09s] DEBUG: Seat seat0: Creating greeter session
[+0.24s] DEBUG: Seat seat0: Creating display server of type x
[+0.26s] DEBUG: Quitting Plymouth
[+0.28s] DEBUG: Using VT 7
[+0.28s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.28s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.28s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.28s] DEBUG: DisplayServer x-0: Launching X Server
[+0.28s] DEBUG: Launching process 1215: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.28s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.28s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.28s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.50s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.50s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+6.21s] DEBUG: Got signal 10 from process 1215
[+6.21s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+6.21s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+6.21s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+6.21s] DEBUG: Session pid=1278: Started with service 'lightdm-greeter', username 'lightdm'
[+6.21s] DEBUG: Greeter closed communication channel
[+6.21s] DEBUG: Session pid=1278: Exited with return value 1
[+6.21s] DEBUG: Session: Failed during authentication
[+6.21s] DEBUG: Seat seat0: Stopping session that failed authentication
[+6.21s] DEBUG: Seat seat0: Session stopped
[+6.21s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+6.21s] DEBUG: Seat seat0: Stopping
[+6.21s] DEBUG: Seat seat0: Stopping display server
[+6.21s] DEBUG: Sending signal 15 to process 1215
[+6.50s] DEBUG: Process 1215 exited with return value 0
[+6.50s] DEBUG: DisplayServer x-0: X server stopped
[+6.50s] DEBUG: Releasing VT 7
[+6.50s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+6.50s] DEBUG: Seat seat0: Display server stopped
[+6.50s] DEBUG: Seat seat0: Stopped
[+6.50s] DEBUG: Required seat has stopped
[+6.50s] DEBUG: Stopping display manager
[+6.50s] DEBUG: Display manager stopped
[+6.50s] DEBUG: Stopping daemon
[+6.50s] DEBUG: Exiting with return value 1

/var/log/x-0.log:

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux FabisLaptop 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-59-generic root=UUID=cbeafd2d-ead6-4060-a2ae-caca82c11c76 ro quiet splash vt.handoff=7
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 27 14:22:26 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(II) Server terminated successfully (0). Closing log file.

/var/log/Xorg.0.log:

I had to remove this file from my post, because it was too log. I can provide it in another comment, if needed, but I could not find anything suspicious in there anyway. the end of the file is the same as of the previous file:

[    40.876] (II) Server terminated successfully (0). Closing log file.

Seams like lightdm tries to start a session, which failes instantly. There is no ~/.Xsession-errors

The configuration:

in /usr/share/lightdm/lightdm.conf.d there are some files which only contain one argument each. Those are:

greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
session-wrapper=/usr/sbin/lightdm-session
user-session=ubuntu
greeter-session=unity-greeter
xserver-command=X -core
backup-logs=false

xorg.conf:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "CustomEDID"            # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "HWRotation"            # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"          # <i>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "EnablePageFlip"        # [<bool>]
        #Option     "ColorTiling"           # [<bool>]
        #Option     "ColorTiling2D"         # [<bool>]
        #Option     "RenderAccel"           # [<bool>]
        #Option     "SubPixelOrder"         # [<str>]
        #Option     "AccelMethod"           # <str>
        #Option     "ShadowPrimary"         # [<bool>]
        #Option     "EXAVSync"              # [<bool>]
        #Option     "EXAPixmaps"            # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "DeleteUnusedDP12Displays"  # [<bool>]
        #Option     "DRI3"                  # [<bool>]
        #Option     "DRI"                   # <i>
        #Option     "TearFree"              # [<bool>]
    Identifier  "Card1"
    Driver      "radeon"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

What I've tried so far

  • change the permissions and ownership of .Xauthority and .ICEauthority to 664 and user:user
  • reconfigure lightdm dpgk-reconfigure lightdm
  • try another greeter
  • uninstall ati driver and reinstall radeon driver apt-get install xserver-xorg-video-radeon
  • remove several files: rm -r ~/.config (e.g. moved to backup) rm ~/.xsession-errors rm ~/.*authority rm /etc/X11/xorg.conf
  • reinstall ubuntu-desktop execstack dh-modaliases debhelper
  • ensure ownership of several libs chown lightdm:lightdm -R /var/lib/lightdm chown avahi-autoipd:avahi-autoipd -R /var/lib/avahi-autoipd chown colord:colord -R /var/lib/colord
  • try to boot with option "xforcevasa"
  • try gdm3 instead of lightdm

This works. kind of...

From the tty I can do:

sudo startx
sudo dconf reset -f /org/compiz
sudo gsettings reset-recursively org.compiz
sudo setsid unity
sudo unity --reset-icons

All together bring back a unity gui. The launcher on the left is available, the only thing that is missing are the icons in the status-bar at the top (shutdown, wifi, ...). Also now I'm logged in as root, not as my user. Maybe this is because I used "sudo" for "setsid unity"..?

With the gui back, I could also start ccsm and ensure that "Ubuntu Unity Plugin" is enabled.

Now after all, I've run out of ideas. I don't know what else to try.

Please help me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.