0

A few days ago I could send emails just fine. Now all the sudden I can not send emails. I just get the error below:

Jan 27 05:25:14 frontier postfix/smtp[22428]: C291A6801DF: to=<@.org>, relay=none, delay=0.03, delays=0.02/0.01/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=*.org type=MX: Host not found, try again)

Something about MX. I can get emails just fine.

  • to=@.org: Is this really the message or did you modify that? If you did, try to check for the MX record of the target domain: host -a <targetdomain> – ridgy Jan 27 '17 at 12:50
  • I removed the email address for privacy reasons. – Fudruckers Jan 27 '17 at 17:58
  • So again: Try host -a <targetdomain>and look if there is an MX record displayed. <targetdomain>means the domain that is mentioned in Name service error for name=<targetdomain> type=MX: Host not found. – ridgy Jan 27 '17 at 18:17
  • Sorry, I don't know how to put the results in a code box. nate@frontier:~$ host -a gmail.com Trying "gmail.com" ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28405 ;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;gmail.com. IN ANY ;; ANSWER SECTION: gmail.com. 299 IN A 216.58.193.101 gmail.com. 299 IN AAAA 2607:f8b0:400a:801::2005 gmail.com. 3599 IN MX 5 gmail-smtp-in.l.google.com. – Fudruckers Jan 27 '17 at 23:55
0

I would make sure you can reach dns and receive replies properly. Make sure you don't have two separate dns servers in your config that are not exact duplicates or it can cause issues of inaccurate dns lookups. If none of this, I would check if your dns provider changed MX records at all.

  • My DNS looks good. Here's a picture of my DNS settings. goo.gl/photos/T2BL6sWo18NX2AJ99 I had not made any changes to the computer that postfix runs on. I only have one DNS setting and that is the router. So the DNS is 192.168.0.1 and the router DNS is 8.8.8.8 and 8.8.4.4. – Fudruckers Jan 27 '17 at 18:12
  • What if you are on the server and do dig commands on the addresses? Do they resolve to the same ips that you have configured? It may be configured correctly, but is that truely how they resolve according to the server's point of view? – Kyle H Jan 27 '17 at 18:27
  • DNS listed as 127.0.1.1 Should be 192.168.0.1 Network manager doing the connection with manual address with DNS of 192.168.0.1 nate@frontier:~$ dig gmail.com ; <<>> DiG 9.10.3-P4-Ubuntu <<>> gmail.com ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26990 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1 ;; OPT PSEUDOSECTION: ; EDNS: version: 0, flags:; udp: 512 ;; QUESTION SECTION: ;gmail.com. IN A ;; ANSWER SECTION: gmail.com. 17 IN A 216.58.193.101 ;; Query time: 69 msec ;; SERVER: 127.0.1.1#53(127.0.1.1) – Fudruckers Jan 28 '17 at 0:28
  • I had an old entry in interfaces. It was commented out. It was #dns-nameserver 8.8.8.8 I removed it completely and rebooted the computer. Presto, several days worth of emails showed up that were from my email server. Dunno why a commented entry would have made a difference. I do have bind9 installed as a recursive DNS. But I have not used it. My interfaces file is now the default on as shipped by Ubuntu 16.10. It's all network manager now. Clarification would be helpful. Appreciated. – Fudruckers Jan 28 '17 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.