4

Hi I am quite new to ubuntu. I am using ubuntu 16.04 in dual boot. My laptop is ASUS bought a little bit more than 3 years ago, with:

Memory: 3.7GiB Processor: Intel® Core™ i7-4500U CPU @ 1.80GHz × 4 Graphics: Intel® Haswell Mobile

The issue is my laptop keeps on freezing, and it's getting more frequent than before. Surprisingly, it also freezes when using ubuntu live from usb.

I have tried updating the kernel, uninstall and reinstall ubuntu but it keeps on freezing. I was thinking that this could be due to a hardware problem, for example, overheating (due to fans not working).

So, here is the output from psensor which I think shows there is no problem with the fan.

image from psensor

EDITED

Here is the image from var/log/syslog

enter image description here

===================================================================

Update 11/02/2017

I am quite sure that the problem is related to hardware, since it only happens when the laptop is not in horizontal position, or when you put some pressure on the laptop. My laptop has been running smoothly since I started avoiding these two things a week ago.

  • What is the model number? You can check for ubuntu certified compatibility here: certification.ubuntu.com/desktop/models/… What do you mean by "laptop keeps freezing"? Does it make ice cubes? ie.. does the screen stop responding? Can you log in to it via ssh from another machine while it is "frozen" (by using openssh-server )? – BenjaminBrink Jan 27 '17 at 8:12
  • Hi @BenjaminBrink thanks for your answer. The model is X550LC. I have checked from the link, and the model is not in the lost. What I meant by "freezing" was everything is not working: keyboard, cursor..I have also tried "Alt + sysrq + REISUB", "x-kill" but they didn't work. I am not sure about ssh, but will have a look at it. – mohd Jan 27 '17 at 8:43
  • list ..sorry for the typo – mohd Jan 27 '17 at 10:43
  • @mohd Are you using a bluetooth mouse or any other extra devices when freeze occurs? – WinEunuuchs2Unix Jan 27 '17 at 11:48
  • @WinEunuuchs2Unix hi thanks. No, I didn't use any other extra devices when that happened. After re-installing ubuntu this afternoon (it has been about 12 hours), the laptop froze only twice. I also managed to use "Alt + sysrq + REISUB", but only once. – mohd Jan 27 '17 at 12:26
0

I experienced a similar problem. I am running ubuntu 16.04.1 with Kernel 4.10.0-30-generic.

I replicated the bug on another distro using a different kernel 4.9 -- debian stable lxde running from a live usb.

After reading many fora and going through several logs, I realised this is nothing but the c-state kernel bug, or at least it has the same solution.

The steps described by Doug solved my problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.