0

I finally got you complete me installed.

The plugin installed sucessfully. But didn't get auto complete as I typed.I looked at the help and tried

:YcmRestartServer

It hangs for several hours.

I issued this command:

:YcmDiags

Here is the output

HTTPConnectionPool(host='127.0.0.1', port=33628): Max retries exceeded with url:
/semantic_completion_available (Caused by  NewConnectionError('<requests.package
s.urllib3.connection.HTTPConnection object at 0x7f7e3f6f2320>: Failed to establi
sh a new connection: [Errno 111] Connection refused',))

How do I fix this ?

  • Which of the previous answers from your previous question helped you install it? – George Udosen Jan 27 '17 at 3:03
  • Well none of them. The steps I put in my previous question I put together from many different google searches. – John G Jan 28 '17 at 3:07
0

i fixed the issue by going in to ~/.vim/bundle/YouCompleteMe/ and running python install.py

  • I got the error Cmake is not able to find Python-libraries. I looked up the solution to this error stackoverflow.com/questions/24174394/… – John G Jan 28 '17 at 17:07
  • forget my last comment – John G Jan 28 '17 at 17:22
  • CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message): Cold NOT find PythonLibs (missing: PYTHON_INCLUDE_DIRS). I set PYTHON_INCLUDE_DIRS = /usr/include/python2.7. thats where mine is – John G Jan 28 '17 at 17:30
  • and got the same error. Also this is my PYTHON_LIBRARY=/usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.so – John G Jan 28 '17 at 17:31
  • okay after doing sudo apt-get install python-dev, python install.py completed without errors. now I'll see if YCM works. – John G Jan 28 '17 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.