0

After a recent update, which included updates for the kernel, I am no longer able to log into GNOME Shell. To clarify the situation, at first it would boot into the GNOME Fallback Session.

To remedy this, I tried installing the Guest Additions again (this has been a problem in the past). However, when I subsequently log in all I am presented with is the desktop. There is no top bar and the windows are undecorated. The only way out it to either trigger an ACPI shutdown or insert a Ctrl+Alt+Del from the VirtualBox Machine menu, which will allow me to restart or log out respectively.

It is possible to log into Unity 3D without any problem, therefore this probably rules out a 3D acceleration issue as well as the Guest Additions not being installed. Any help would be appreciated!

1

I have actually just solved the problem, but will keep my question up here in case any other users have the same problem. The solution is to reinstall the GNOME Shell package. To do this, in the terminal type:

sudo apt-get install --reinstall gnome-shell

Once this has finished, log out of your current session and then choose the GNOME session. In my case

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.