0

I am trying to simulate each type of routing protocoles in NS2. I started with AODV and DSDV, it worked very well, but when I tried to simulate DSR I got this error "core dumped", and for OLSR and ZRP I got this one:

    (_o16 cmd line 1)
    invoked from within
"_o16 cmd addr"
    invoked from within
"catch "$self cmd $args" ret"
    invoked from within
"if [catch "$self cmd $args" ret] {
set cls [$self info class]
global errorInfo
set savedInfo $errorInfo
error "error when calling class $cls: $args" $..."
    (procedure "_o16" line 2)
    (SplitObject unknown line 2)
    invoked from within
"_o16 addr"
    ("eval" body line 1)
    invoked from within
"eval $node addr $args"
    ("default" arm line 2)
    invoked from within
"switch -exact $routingAgent_ {
DSDV {
set ragent [$self create-dsdv-agent $node]
}
DSR {
$self at 0.0 "$node start-dsr"
}
AODV {
set ragent [$self cre..."
    (procedure "_o3" line 14)
    (Simulator create-wireless-node line 14)
    invoked from within
"_o3 create-wireless-node"
    ("eval" body line 1)
    invoked from within
"eval $self create-wireless-node $args"
    (procedure "_o3" line 23)
    (Simulator node line 23)
    invoked from within
"$ns_ node"
    ("for" body line 2)
    invoked from within
"for {set i 0} {$i < $opt(nn) } {incr i} {
set node_($i) [$ns_ node]
$node_($i) random-motion 0 ;# disable random motion
}"
    (file "zrp.tcl" line 110)

Can anyone help me please?

0

AODV and DSR are default applications in ns2.

ZRP can be added to ns-2.35 with the patch zrp-ns235.patch ... Build examples, post #22 here and post 9/8/15 here

OLSR can be added to the ZRP patched ns-2.35 with umolsr_for-zrp-patched_ns235.patch

Valid simulation examples:

  1. OLSR: umolsr-examples-05.2016.tar.gz
  2. ZRP: zrp-examples-05.2016.tar.gz

      -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.