I'd like to disable my touchpad while typing, per instructions on https://help.ubuntu.com/11.10/ubuntu-help/mouse-disabletouchpad.html

Sadly, my 11.10 installation does not have any other tab than 'mouse' in 'System Settings' -> 'Mouse and Touchpad'

From what I can tell, the touchpad is detected (and functioning) properly:

guus@laptop-guus:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ImPS/2 ALPS GlidePoint                    id=13   [slave  pointer  (2)]
⎜   ↳ Dell Dell USB Mouse                       id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_FHD              id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]

Can anyone suggest how to enable the 'disable while typing' feature?

  • Beta 2 of 12.04 gives me this encouraging output for xinput list - sadly, the 'System Settings' have disappeared, so I can't verify my Mouse and Touchpad settings right now.
    – Guus
    Apr 11, 2012 at 9:25

5 Answers 5


Your touchpad is not being detected as a touchpd, it is being detected as a mouse. That's why you can use the touchpad but you see no tab to configure it.

It is a known bug and is reported here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/760142

You can see the same talk in UbuntuForums http://ubuntuforums.org/showthread.php?t=1833606

I used to have the same problem with an Elantech touchpad but It was solved in the previous kernel update. If you are lucky, in two or tree months it will be solved in a update (or not!)

Meanwhile you can read the bug report to see if there is a fix, or something you can try.

  • The patch provided in #81 appears to have resolved the issue.
    – Guus
    Dec 18, 2011 at 18:55

this may help install gsynaptics and change the setting from it. by the way you should already have xserver-xorg-input-synaptics installed which is the tool in system settings - mouse and touchpad - touchpad

  • the gsynaptics package gives me the gpointing-device-settings executable. This lists two mouses: 'ImPS/2 ALPS GlidePoint' and 'Dell Dell USB Mouse.' Is my touchpad falsly identified as a mouse? How to remedy that?
    – Guus
    Dec 14, 2011 at 9:35

You can try with gpointing-device-settings that is an interface to gsynaptics and it allows you to customize touchpad and mouse as you prefer..


My notebook also doesn't have the tab "touchpad" under "system preferences > mouse and touchpad" menu. But i found some settings in dconf-editor, under the "org > gnome > settings daemon > peripherals > touchpad" options. Using this i could disable the touchpad while typing. Hope it will fit for you!


I lost the Touchpad settings tab too, while playing around with the utitouch Driver, and I got it back with the instructions i wrote here. Maybe the synaptics packages to install are the same for other computers. I hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.