I have googled and searched and i want to move back to windows (as this setup works FLAWLESSLY with windows 10, sigh)

I have an MSI A68HI-AC mb with A10-something CPU, 12GB ram, a shiney gigabte RX 460 2gb gfx card and much much pain.

1 week trying to get hardware graphics on this on Linux, I've re-installed more than 10 times with Kubuntu, mint and ubuntu.

Currently i have ubuntu 14.04.1 and updated the kernel to 4.9. This is the MOST i have advanced and its still working, the other distros all crashed X / Xorg / grafics anything at this point. And yes, i even tried 17.3, 14.4 and flicking up and down kernels with each distro. I'm serious when I said I have tried a LOT of alternate "fixes".

kernel 4.9 It apparently has improved support for ATI/AMD GPUs. apparently. i cant copy and paste stuff from the Linux box as I am writing this from my working windows 8.1 laptop.

$ lspci | grep VGA
VGA compatible controller Kaveri R7                ## assuming its my on-cpu graphics
VGA compatible controller Device 67ef (rev cf)     ## assuming my RX 460?

$ glxinfo | grep OpenGL
renderer string: Gallium 0.4               ## I assume again this is onboard/CPU and not GPU)
core profile string: 3.3 Mesa 17.1.0-devel1 - padoka PPA
version string: 3.0 mesa
ES profile string: OpenGL ES 3.0

I am about to install the AMDGPU-Pro ...annnnnnd it gone. I need to log in to the pc using Ctrl-Alt-F4

2 Answers 2


welcome to the community.

I was going to suggest triple-checking that the graphics card has power. However, you mentioned that the setup works with Windows 10. That indicates to me that the hardware inside the box is set up in a good way.

It is possible that you do not have the driver installed for your graphics card.

  • Low-hanging fruit: Main menu, Additional Drivers. See if your card shows up there.

  • Ubuntu has some wiki documentation on installing AMD drivers.

  • Finally, you might be able to install the driver manually. This would simply consist of downloading a zipped archive, unzipping, and placing in the correct folder (perhaps using sudo access).

I'm sorry to hear about your struggle, though I will admit, I am impressed by your persistence. You definitely have been putting in the blood sweat and tears - good luck!

  • 1
    I have just added and removed twice: AMDGPU-Pro as it failed both times, and only allowed me to login via command terminal. funny cause it shows the graphical login. ive just tried editing the auto login part (not one person online can write a step-by-step procedure it seems) fail. at every point, using AMDs propriety driver, mesa (black mesa, half life?) 2 different PPS and holding my breathe while sucking on a rainbow parakeet, or whatever god-ever driver anyone cares to call it, nothing has ever shown up as hardware rendering, always the CPU software rendering gallium driver.
    – drjam
    Jan 26, 2017 at 4:55
  • 1
    just got the second monitor working!!!! (although "about this computer" says "Gallium 0.4 on AMD POLARIS11 (DRM 3.8.0 / 4.9.0-040900-generic, LLVM 5.0.0)" still fail? First i .... I installed the new AMDGPU-Pro drivers that came out today. Typically failed reboot graphical login, removed, rebooted then did this: sudo update-pciids #optional command, requires internet lspci | grep -E 'VGA|Display' dmesg | egrep 'drm|radeon' this shows boot errors, cool! showed VGACON disables amdgpu kernel modsetting. sudo pluma /etc/default/grub and commented out (use: #) nomodset
    – drjam
    Jan 27, 2017 at 13:07

Getting hardware accel to work needed: https://help.ubuntu.com/community/RadeonDriver and https://bbs.archlinux.org/viewtopic.php?id=166037 ..... main part was removing nomodeset from grub's boot..... removed also noacpi or something. I now have a working card with dual screens. May this help all others! thank you for helping me too nshiff oh, use
dmesg | egrep 'drm|radeon' #as this was the turning point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.