I've found many solutions but I do want to understand why this happens. I use English (US, International with dead keys) layout because I am a Portuguese speaker, and it's better for me not to change the layout all the time, not to mention I'm used with the US layout and key positions etc.

Yesterday I re-installed Xubunt 16.04.1 64bits and after installing the packages bumblebee and bumblebee-nvidia, I ran into this issue - again - of every reboot the layout is changed to simple English (US), where the special accents that exist in the Portuguese language. To make them, I'd press the key and then the letter, but with this layout that's changed after each reboot, by pressing the special character will simply print it immediately.

In the Settings > Keyboard > Layouts is set to the option I chose during installation, by default, but still, it insists on change.

Curiously, the previous installation of the system took around two weeks or three for it to happen, while this time, the same day.

Why does it happen? I know it's not only me.


Make sure you have system keyboard layout enabled on ibus-setup:

  1. Press Alt + F2 and run ibus-setup on command field.
  2. New window will appeared, navigate to Advanced tab.
  3. Check Use system keyboards layout option.
  4. Close the window.

Then, disable Use system Defaults item from Keyboard settings:

  1. Go to Settings > Keyboard > Layout tab.
  2. Uncheck Use system defaults.
  3. Close the window.

Add setxkbmap us -variant intl command to $HOME/.profile:

echo setxkbmap us -variant intl >> $HOME/.profile

This command should set English (US, International with dead keys) layout on every login.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.